summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <crabbedhaloablution@icloud.com>2020-12-15 12:43:10 +0100
committerSam James <sam@gentoo.org>2021-02-08 14:53:58 +0000
commit281e0e7ae7ed000d93843ad33319acf70c625c18 (patch)
tree8e9a319fa3fd62199e27e74b38be5c6f61502568 /net-misc/chrony
parentdev-libs/crypto++: fix musl build (diff)
downloadgentoo-281e0e7ae7ed000d93843ad33319acf70c625c18.tar.gz
gentoo-281e0e7ae7ed000d93843ad33319acf70c625c18.tar.bz2
gentoo-281e0e7ae7ed000d93843ad33319acf70c625c18.zip
net-misc/chrony: add nss support
NSS is no longer a null-option. Do note that with --as-needed, chronyd will only link against libfreebl3.so, not other parts of NSS. NSS, though, is kind of useless since it's only good for sechash support. Signed-off-by: Peter Alfredsen <crabbedhaloablution@icloud.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/chrony')
-rw-r--r--net-misc/chrony/chrony-9999.ebuild14
-rw-r--r--net-misc/chrony/metadata.xml1
2 files changed, 10 insertions, 5 deletions
diff --git a/net-misc/chrony/chrony-9999.ebuild b/net-misc/chrony/chrony-9999.ebuild
index 705bbb05914e..81b51b9af840 100644
--- a/net-misc/chrony/chrony-9999.ebuild
+++ b/net-misc/chrony/chrony-9999.ebuild
@@ -20,8 +20,13 @@ S="${WORKDIR}/${P/_/-}"
LICENSE="GPL-2"
SLOT="0"
-IUSE="+caps +cmdmon html ipv6 libedit +nettle +ntp +phc pps +refclock +rtc samba +seccomp +sechash selinux"
-REQUIRED_USE="sechash? ( nettle )"
+IUSE="+caps +cmdmon html ipv6 libedit +nettle nss +ntp +phc pps +refclock +rtc samba +seccomp +sechash selinux"
+REQUIRED_USE="
+ sechash? ( || ( nettle nss ) )
+ nettle? ( !nss )
+ !sechash? ( !nss )
+ !sechash? ( !nts? ( !nettle ) )
+ "
RESTRICT="test"
BDEPEND="nettle? ( virtual/pkgconfig )"
@@ -40,6 +45,7 @@ DEPEND="
)
libedit? ( dev-libs/libedit )
nettle? ( dev-libs/nettle:= )
+ nss? ( dev-libs/nss:= )
seccomp? ( sys-libs/libseccomp )
html? ( dev-ruby/asciidoctor )
pps? ( net-misc/pps-tools )
@@ -84,8 +90,6 @@ src_configure() {
tc-export CC PKG_CONFIG
- # Note: ncurses and nss switches are mentioned in the configure script but
- # do nothing
# not an autotools generated script
local myconf=(
$(use_enable seccomp scfilter)
@@ -94,6 +98,7 @@ src_configure() {
$(usex ipv6 '' --disable-ipv6)
$(usex libedit '' --without-editline)
$(usex nettle '' --without-nettle)
+ $(usex nss '' --without-nss)
$(usex ntp '' --disable-ntp)
$(usex phc '' --disable-phc)
$(usex pps '' --disable-pps)
@@ -109,7 +114,6 @@ src_configure() {
--sysconfdir="${EPREFIX}/etc/chrony"
--with-hwclockfile="${EPREFIX}/etc/adjtime"
--with-pidfile="${EPREFIX}/run/chrony/chronyd.pid"
- --without-nss
--without-tomcrypt
)
diff --git a/net-misc/chrony/metadata.xml b/net-misc/chrony/metadata.xml
index 6d7a44f2f91e..fe7394a48bfa 100644
--- a/net-misc/chrony/metadata.xml
+++ b/net-misc/chrony/metadata.xml
@@ -26,6 +26,7 @@
<flag name="cmdmon">Support for command and monitoring</flag>
<flag name="html">Install HTML documentation</flag>
<flag name="nettle">Use <pkg>dev-libs/nettle</pkg> for hash functions</flag>
+ <flag name="nss">Use <pkg>dev-libs/nss</pkg> for hash functions</flag>
<flag name="ntp">Support for the Network Time Protocol (NTP)</flag>
<flag name="phc">Support for the PTP (Precision Time Protocol) Hardware Clock (PHC) interface</flag>
<flag name="pps">Support for the Linux Pulse Per Second (PPS) interface</flag>