summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-11-21 20:03:21 +0100
committerJeroen Roovers <jer@gentoo.org>2016-11-21 20:10:06 +0100
commitbeeb3f0148411e83ea72bd298943e71029f49d1a (patch)
tree0879b5a2e382c10749ba138b4940c62e01a131b9 /net-misc/chrony
parentx11-drivers/nvidia-drivers: Version bump. (diff)
downloadgentoo-beeb3f0148411e83ea72bd298943e71029f49d1a.tar.gz
gentoo-beeb3f0148411e83ea72bd298943e71029f49d1a.tar.bz2
gentoo-beeb3f0148411e83ea72bd298943e71029f49d1a.zip
net-misc/chrony: Version bump.
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-misc/chrony')
-rw-r--r--net-misc/chrony/Manifest1
-rw-r--r--net-misc/chrony/chrony-2.4.1.ebuild120
2 files changed, 121 insertions, 0 deletions
diff --git a/net-misc/chrony/Manifest b/net-misc/chrony/Manifest
index 99b02a760f1a..86c52794e701 100644
--- a/net-misc/chrony/Manifest
+++ b/net-misc/chrony/Manifest
@@ -1,3 +1,4 @@
DIST chrony-2.2.1.tar.gz 340514 SHA256 4776fa8e80d698723e9a88eb882170951f6c45860545d84ae9f9d8b9bbd73796 SHA512 caa18a22e7e64186f24f474e02862296bfa74c99671bc98e926caf27b88ce3580282543594602e76ad4be9b7f9623350888def893a7c1d96a7370d13a636442f WHIRLPOOL 77500bc25496dc15f17bce60023b86330205945999011b243272db26a924ac67193da70089c59e19bea7666c05059c8c4c1975ca19057775ec2dd8e468ab8dce
DIST chrony-2.3.tar.gz 355113 SHA256 58bffb523012fb0fa87cc0d94d6e36de9689fe9556519cbd0d1ba254af92ccb2 SHA512 2a9cda6c2bc931438b798bd037614196bdb1533d12432467a690d57095c74013c80c92fcaadbd43fd5b0c816872822527a1ade3014add458d669d7813d5fa080 WHIRLPOOL 06864181ac74b2cf13baf7d9098404f8540c26db41035fe38005fbfea8e12f2de179008f5b1a2544e24ebb7e4cca712421746690edb7f36b90416ad87901e920
+DIST chrony-2.4.1.tar.gz 390641 SHA256 0fd59e0ef625b4459e3a9c7f221c52f56596582bce31abfae5f7369702edb6e0 SHA512 7772065103ad95706f80374d88ba452b76cf8e29689abf22b38e7eb5ad2fcc491593e11702400daa8bf908218614df21b08ff15ab2d3d2347876119cd80abc4d WHIRLPOOL ed2c2ac8e11371e009d3e96553bb73e58b410bb38e6123a9e39a3451e5dc6860d981d45e67b4e2dc47b39f616f95146feb35efd15dbaa90932f07837172c440a
DIST chrony-2.4.tar.gz 390077 SHA256 8d04e7cda2333289c2104b731d39c3c1db94816e43bae35d7ee4e7ae8af6391f SHA512 29bbeba05fb9897d438cddca7dd4e573a1e9da0d583bd737185088e8b777fdfba4056d091d2bbab78824de284b6244a8de7ada8f62be316e815a3d8ae6145485 WHIRLPOOL 7ad8b17ee8c29afa6734b7f096bb56bc08cfb200747141f0fa77e6a37daab118e1c571b8869abcab7e4893ae3eaae6a6d783425058bbaf8508cbd8de215cb49d
diff --git a/net-misc/chrony/chrony-2.4.1.ebuild b/net-misc/chrony/chrony-2.4.1.ebuild
new file mode 100644
index 000000000000..45904cc4c0b9
--- /dev/null
+++ b/net-misc/chrony/chrony-2.4.1.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils systemd toolchain-funcs
+
+DESCRIPTION="NTP client and server programs"
+HOMEPAGE="http://chrony.tuxfamily.org/"
+SRC_URI="http://download.tuxfamily.org/${PN}/${P/_/-}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64"
+IUSE="caps +cmdmon html ipv6 libedit +ntp +phc pps readline +refclock +rtc selinux +adns"
+REQUIRED_USE="
+ ?? ( libedit readline )
+"
+
+CDEPEND="
+ caps? ( sys-libs/libcap )
+ libedit? ( dev-libs/libedit )
+ readline? ( >=sys-libs/readline-4.1-r4:= )
+"
+DEPEND="
+ ${CDEPEND}
+ html? ( dev-ruby/asciidoctor )
+ pps? ( net-misc/pps-tools )
+"
+RDEPEND="
+ ${CDEPEND}
+ selinux? ( sec-policy/selinux-chronyd )
+"
+
+RESTRICT=test
+
+S="${WORKDIR}/${P/_/-}"
+
+src_prepare() {
+ sed -i \
+ -e 's:/etc/chrony\.:/etc/chrony/chrony.:g' \
+ -e 's:/var/run:/run:g' \
+ conf.c doc/*.man.in examples/* || die
+
+ default
+}
+
+src_configure() {
+ tc-export CC
+
+ local CHRONY_EDITLINE
+ # ./configure legend:
+ # --disable-readline : disable line editing entirely
+ # --without-readline : do not use sys-libs/readline (enabled by default)
+ # --without-editline : do not use dev-libs/libedit (enabled by default)
+ if ! use readline && ! use libedit; then
+ CHRONY_EDITLINE='--disable-readline'
+ else
+ CHRONY_EDITLINE+=" $(usex readline '' --without-readline)"
+ CHRONY_EDITLINE+=" $(usex libedit '' --without-editline)"
+ fi
+
+ # not an autotools generated script
+ local CHRONY_CONFIGURE="
+ ./configure \
+ $(usex caps '' --disable-linuxcaps) \
+ $(usex cmdmon '' --disable-cmdmon) \
+ $(usex ipv6 '' --disable-ipv6) \
+ $(usex ntp '' --disable-ntp) \
+ $(usex phc '' --disable-phc) \
+ $(usex pps '' --disable-pps) \
+ $(usex rtc '' --disable-rtc) \
+ $(usex refclock '' --disable-refclock) \
+ $(usex adns '' --disable-asyncdns) \
+ ${CHRONY_EDITLINE} \
+ ${EXTRA_ECONF} \
+ --docdir=/usr/share/doc/${PF} \
+ --chronysockdir=/run/chrony \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --sysconfdir=/etc/chrony \
+ --disable-sechash \
+ --without-nss \
+ --without-tomcrypt
+ "
+
+ # print the ./configure call to aid in future debugging
+ einfo ${CHRONY_CONFIGURE}
+ bash ${CHRONY_CONFIGURE} || die
+}
+
+src_compile() {
+ emake all docs $(usex html '' 'ADOC=true')
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/chronyd.init-r1 chronyd
+ newconfd "${FILESDIR}"/chronyd.conf chronyd
+
+ insinto /etc/${PN}
+ newins examples/chrony.conf.example1 chrony.conf
+
+ docinto examples
+ dodoc examples/*.example*
+
+ if use html; then
+ docinto html
+ dodoc doc/*.html
+ fi
+
+ keepdir /var/{lib,log}/chrony
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/chrony-2.4-r1.logrotate chrony
+
+ systemd_newunit "${FILESDIR}"/chronyd.service-r2 chronyd.service
+ systemd_enable_ntpunit 50-chrony chronyd.service
+}