summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2016-10-04 10:37:12 +0200
committerMarek Szuba <marecki@gentoo.org>2016-10-04 10:40:58 +0200
commite99694ae5e0b3535697f2a5a982398cb8618abeb (patch)
tree7bdb220e173eb239f8d40b83bbed12848dfee1f6 /net-misc/connman-gtk/connman-gtk-1.1.1.ebuild
parentsys-apps/pciutils: Bump to version 3.5.2 (diff)
downloadgentoo-e99694ae5e0b3535697f2a5a982398cb8618abeb.tar.gz
gentoo-e99694ae5e0b3535697f2a5a982398cb8618abeb.tar.bz2
gentoo-e99694ae5e0b3535697f2a5a982398cb8618abeb.zip
net-misc/connman-gtk: version bump to 1.1.1
Includes an update to EAPI 6. Package-Manager: portage-2.3.1
Diffstat (limited to 'net-misc/connman-gtk/connman-gtk-1.1.1.ebuild')
-rw-r--r--net-misc/connman-gtk/connman-gtk-1.1.1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-misc/connman-gtk/connman-gtk-1.1.1.ebuild b/net-misc/connman-gtk/connman-gtk-1.1.1.ebuild
new file mode 100644
index 000000000000..fd870845a5cb
--- /dev/null
+++ b/net-misc/connman-gtk/connman-gtk-1.1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools gnome2-utils
+
+DESCRIPTION="GTK GUI for Connman"
+HOMEPAGE="https://github.com/jgke/connman-gtk"
+SRC_URI="https://github.com/jgke/connman-gtk/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="openconnect"
+
+CDEPEND="
+ >=dev-libs/glib-2.0:2
+ >=x11-libs/gtk+-3.10:3
+ openconnect? ( >=net-misc/openconnect-5.99 )
+"
+RDEPEND="${CDEPEND}
+ net-misc/connman
+"
+DEPEND="${CDEOEND}
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ sed -i -e '/^Categories/ s/$/;/' connman-gtk.desktop.in || die
+ eautoreconf
+}
+
+src_configure() {
+ default
+ econf \
+ --disable-schemas-compile \
+ $(use_with openconnect)
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}