summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2018-12-06 23:19:43 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2018-12-06 23:20:18 +0100
commit285a78869a91ee880369c230ab3fe241ca3d05b9 (patch)
tree6b57c3e3bef3fc76a30d7da586a7a227881f4ba7 /net-misc/csync/csync-0.50.0-r1.ebuild
parentnet-wireless/soapyremote: bump, add missing dep (diff)
downloadgentoo-285a78869a91ee880369c230ab3fe241ca3d05b9.tar.gz
gentoo-285a78869a91ee880369c230ab3fe241ca3d05b9.tar.bz2
gentoo-285a78869a91ee880369c230ab3fe241ca3d05b9.zip
net-misc/csync: fix compilation with GCC 8
Update ebuild (EAPI, patch, samba conditional) Closes: https://bugs.gentoo.org/671094 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-misc/csync/csync-0.50.0-r1.ebuild')
-rw-r--r--net-misc/csync/csync-0.50.0-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-misc/csync/csync-0.50.0-r1.ebuild b/net-misc/csync/csync-0.50.0-r1.ebuild
new file mode 100644
index 000000000000..5374066247df
--- /dev/null
+++ b/net-misc/csync/csync-0.50.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="lightweight file synchronizer utility"
+HOMEPAGE="https://www.csync.org/"
+SRC_URI="https://open.cryptomilk.org/attachments/download/27/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc iconv samba +sftp test"
+
+RDEPEND=">=dev-db/sqlite-3.4:3
+ net-libs/neon[ssl]
+ iconv? ( virtual/libiconv )
+ samba? ( >=net-fs/samba-3.5 )
+ sftp? ( >=net-libs/libssh-0.5 )
+ !net-misc/ocsync"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cmocka )"
+
+PATCHES=( "${FILESDIR}"/${P}-gcc_5_and_8.patch )
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # proper docdir
+ sed -e "s:/doc/${PN}:/doc/${PF}:" \
+ -i doc/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
+ -DWITH_ICONV="$(usex iconv)"
+ -DUNIT_TESTING="$(usex test)"
+ $(cmake-utils_use_find_package doc Doxygen)
+ $(cmake-utils_use_find_package samba SMBClient)
+ $(cmake-utils_use_find_package sftp LibSSH)
+ )
+ cmake-utils_src_configure
+}