summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2020-06-11 21:59:13 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-06-25 14:18:23 +0300
commite218181a346d02f68e92267d94f299319104d3b6 (patch)
treef720af0ad04dc0b3d0f53349c7104dccb9613d9f /net-misc/dahdi
parentapp-emulation/virtio-win: version bump to 0.1.185.1 (diff)
downloadgentoo-e218181a346d02f68e92267d94f299319104d3b6.tar.gz
gentoo-e218181a346d02f68e92267d94f299319104d3b6.tar.bz2
gentoo-e218181a346d02f68e92267d94f299319104d3b6.zip
net-misc/dahdi: fix install issue w.r.t. depmod.
If the kernel sources are not yet compiled, then there is no System.map, and as a result the kernel build system won't run depmod, resulting in the modules.* files normally generated by this to not exist. This causes the rm in the ebuild to fail. Substitute with a find mechanism that only deletes if it exists. At the same time clean up some empty files on the image that carries firmware version information which we don't care about. Closes: https://bugs.gentoo.org/725022 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Closes: https://github.com/gentoo/gentoo/pull/16196 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc/dahdi')
-rw-r--r--net-misc/dahdi/dahdi-3.1.0-r1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-misc/dahdi/dahdi-3.1.0-r1.ebuild b/net-misc/dahdi/dahdi-3.1.0-r1.ebuild
index bd1d6c11293c..f69efcbe4185 100644
--- a/net-misc/dahdi/dahdi-3.1.0-r1.ebuild
+++ b/net-misc/dahdi/dahdi-3.1.0-r1.ebuild
@@ -97,5 +97,11 @@ src_install() {
DAHDI_MODULES_EXTRA="${JNET_DRIVERS// /.o }.o$(usex oslec " dahdi_echocan_oslec.o" "")" \
LDFLAGS="$(raw-ldflags)" install
- rm -r "${ED}"/lib/modules/*/modules.* || die "Error removing bogus modules"
+ # Remove the blank "version" files (these files are all empty, and root owned).
+ find "${ED}/lib/firmware" -name ".*" -delete || die "Error removing empty firmware version files"
+
+ # If the kernel sources have a System.map, and there a suitable depmod
+ # available (seemingly when we're not cross-compiling), then the kernel
+ # sources depmod kicks in. Remove the files caused by that.
+ find "${ED}/lib/modules" -name "modules.*" -delete || die "Error deleting bogus modules.* files"
}