summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-06-28 00:32:53 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-06-28 12:46:14 +0200
commit268cc9c9d632a28c6319ea9aaf175deb18dee281 (patch)
tree459ceb8a43cfd87926ee9b4be179d3970ec4d0e5 /net-misc/datapipe
parentsci-mathematics/fricas: bump to 1.3.4 (diff)
downloadgentoo-268cc9c9d632a28c6319ea9aaf175deb18dee281.tar.gz
gentoo-268cc9c9d632a28c6319ea9aaf175deb18dee281.tar.bz2
gentoo-268cc9c9d632a28c6319ea9aaf175deb18dee281.zip
net-misc/datapipe: EAPI 6 bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-misc/datapipe')
-rw-r--r--net-misc/datapipe/datapipe-1.0-r2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-misc/datapipe/datapipe-1.0-r2.ebuild b/net-misc/datapipe/datapipe-1.0-r2.ebuild
new file mode 100644
index 000000000000..503b4e448264
--- /dev/null
+++ b/net-misc/datapipe/datapipe-1.0-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="bind a local port and connect it to a remote socket"
+HOMEPAGE="http://http.distributed.net/pub/dcti/unsupported/"
+SRC_URI="ftp://ftp.distributed.net/pub/dcti/unsupported/${P}.tar.gz http://http.distributed.net/pub/dcti/unsupported/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~arm ~amd64"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o datapipe datapipe.c
+}
+
+src_install() {
+ einstalldocs
+ dobin datapipe
+ dodoc datapipe.txt
+}