summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-04-21 11:28:39 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-04-21 11:28:48 +0200
commit12b4d8f06024aba59d700e6b3c40ae5b46ed9d26 (patch)
tree5cc1c2e35fec7c271ec69c2a6e4bb375cdd3e5a6 /net-misc/dhcp
parentdev-games/tiled: versiom bump 1.3.4 (diff)
downloadgentoo-12b4d8f06024aba59d700e6b3c40ae5b46ed9d26.tar.gz
gentoo-12b4d8f06024aba59d700e6b3c40ae5b46ed9d26.tar.bz2
gentoo-12b4d8f06024aba59d700e6b3c40ae5b46ed9d26.zip
net-misc/dhcp: Fix build with gcc-10
Bug: https://bugs.gentoo.org/710194 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-misc/dhcp')
-rw-r--r--net-misc/dhcp/dhcp-4.4.2-r2.ebuild3
-rw-r--r--net-misc/dhcp/files/dhcp-4.4.2-fno-common.patch34
2 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/dhcp/dhcp-4.4.2-r2.ebuild b/net-misc/dhcp/dhcp-4.4.2-r2.ebuild
index 650a485d9d6f..8adf530720e3 100644
--- a/net-misc/dhcp/dhcp-4.4.2-r2.ebuild
+++ b/net-misc/dhcp/dhcp-4.4.2-r2.ebuild
@@ -67,6 +67,9 @@ PATCHES=(
"${FILESDIR}/${PN}-4.3.6-iproute2-path.patch" #480636
"${FILESDIR}/${PN}-4.2.5-bindtodevice-inet6.patch" #471142
"${FILESDIR}/${PN}-4.3.3-ldap-ipv6-client-id.patch" #559832
+
+ # Possible upstream candidates
+ "${FILESDIR}/${PN}-4.4.2-fno-common.patch" #710194
)
src_prepare() {
diff --git a/net-misc/dhcp/files/dhcp-4.4.2-fno-common.patch b/net-misc/dhcp/files/dhcp-4.4.2-fno-common.patch
new file mode 100644
index 000000000000..5d0b7bdd5352
--- /dev/null
+++ b/net-misc/dhcp/files/dhcp-4.4.2-fno-common.patch
@@ -0,0 +1,34 @@
+--- a/client/dhclient.c
++++ b/client/dhclient.c
+@@ -83,8 +83,6 @@
+ static const char url [] = "For info, please visit https://www.isc.org/software/dhcp/";
+ #endif /* UNIT_TEST */
+
+-u_int16_t local_port = 0;
+-u_int16_t remote_port = 0;
+ #if defined(DHCPv6) && defined(DHCP4o6)
+ int dhcp4o6_state = -1; /* -1 = stopped, 0 = polling, 1 = started */
+ #endif
+--- a/relay/dhcrelay.c
++++ b/relay/dhcrelay.c
+@@ -95,9 +95,6 @@
+ forward_untouched, /* Forward without changes. */
+ discard } agent_relay_mode = forward_and_replace;
+
+-u_int16_t local_port;
+-u_int16_t remote_port;
+-
+ /* Relay agent server list. */
+ struct server_list {
+ struct server_list *next;
+--- a/server/mdb.c
++++ b/server/mdb.c
+@@ -67,8 +67,6 @@
+
+ int numclasseswritten;
+
+-omapi_object_type_t *dhcp_type_host;
+-
+ isc_result_t enter_class(cd, dynamicp, commit)
+ struct class *cd;
+ int dynamicp;