summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/efax
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/efax')
-rw-r--r--net-misc/efax/Manifest2
-rw-r--r--net-misc/efax/efax-0.9a-r4.ebuild40
-rw-r--r--net-misc/efax/files/efax-0.9a-fax-command.patch10
-rw-r--r--net-misc/efax/metadata.xml7
4 files changed, 59 insertions, 0 deletions
diff --git a/net-misc/efax/Manifest b/net-misc/efax/Manifest
new file mode 100644
index 000000000000..a49112b4e276
--- /dev/null
+++ b/net-misc/efax/Manifest
@@ -0,0 +1,2 @@
+DIST efax-0.9a-001114.tar.gz 97402 SHA256 46abddf13f7565ea0c9d85b92845cdb32fb265c47cfc84c972e11a0219cda8ea SHA512 b6361f84a8239e515cf29dbcbfde3d38648b73e7acfc72a0e2ced4ff2dd801c73bbccf5d34fb8aa065ec8b8bfc694a58f6d8dc00bb9e9a63e580be618a45228b WHIRLPOOL 790aa776668f58aaea3b1be16daec47e223fea08e8104647427bc80d63b52037ac526f2d8696dc3d93b2ff6efd7bb7b0b6c7bbc251d5db911788b805d13b6f01
+DIST efax_0.9a-19.diff.gz 18178 SHA256 eb039ae8e4be159e262bbb11e1de5596b249ba22f67a9bd3bfdbab0da3964197 SHA512 8b1a2d007ebba73b772400eb1e0ccc61d832775590ac4fd6e171008c9741409118db099b444dc8da04dd87f1cb7025a9af62f60b2c3ccba21cc89863a2909735 WHIRLPOOL 521e647c564216d016efa1cf763fb9ca5977effe310be3db05c9d0401eea25c9bc41e58ddadcd711a4e7f96b034efce189ea346866c86cff30cd3212f1e0c4d8
diff --git a/net-misc/efax/efax-0.9a-r4.ebuild b/net-misc/efax/efax-0.9a-r4.ebuild
new file mode 100644
index 000000000000..b4627f25d454
--- /dev/null
+++ b/net-misc/efax/efax-0.9a-r4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+S="${WORKDIR}/${P}-001114"
+
+DESCRIPTION="A simple fax program for single-user systems"
+HOMEPAGE="http://www.cce.com/efax"
+SRC_URI="http://www.cce.com/efax/download/${P}-001114.tar.gz
+ mirror://debian/pool/main/e/efax/efax_0.9a-19.diff.gz"
+
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+
+src_prepare () {
+ epatch "${WORKDIR}/${PN}_${PV}-19.diff"
+ rm -f "${S}"/${P}/debian/patches/series "${S}"/${P}/debian/patches/00list
+ EPATCH_FORCE="yes" epatch "${S}"/${P}/debian/patches/*
+
+ epatch "${FILESDIR}/${P}-fax-command.patch" #327737
+
+ # remove strip command as per bug #240932
+ sed -i -e '/strip/d' Makefile
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install () {
+ dobin efax efix fax
+ doman efax.1 efix.1
+ newman fax.1 efax-fax.1 # Don't collide with net-dialup/mgetty, bug #429808
+ dodoc README
+}
diff --git a/net-misc/efax/files/efax-0.9a-fax-command.patch b/net-misc/efax/files/efax-0.9a-fax-command.patch
new file mode 100644
index 000000000000..92bec22aa879
--- /dev/null
+++ b/net-misc/efax/files/efax-0.9a-fax-command.patch
@@ -0,0 +1,10 @@
+--- fax 2010/07/11 02:05:19 1.1
++++ fax 2010/07/11 02:05:37
+@@ -773,6 +773,7 @@
+ $GS -q -sDEVICE=tiffg3 -r$RES -dNOPAUSE -dSAFER \
+ -sOutputFile=$BASENAME.%03d \
+ -sPAPERSIZE=$PAGE \
++ -dMaxStripSize=0 \
+ $BASENAME </dev/null >/dev/null )
+ ;;
+ II*|MM*|P4*)
diff --git a/net-misc/efax/metadata.xml b/net-misc/efax/metadata.xml
new file mode 100644
index 000000000000..d9cd2cad66c2
--- /dev/null
+++ b/net-misc/efax/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>