summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-21 13:36:47 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-21 13:37:41 +0200
commit37e3998a29b4758e6a11a5c42320344f4139689b (patch)
treef15416f92b5b60fae62783abc4c1f3bed2a99539 /net-misc/fatrat
parentx11-misc/fraqtive: Fix build with Qt 5.15 (diff)
downloadgentoo-37e3998a29b4758e6a11a5c42320344f4139689b.tar.gz
gentoo-37e3998a29b4758e6a11a5c42320344f4139689b.tar.bz2
gentoo-37e3998a29b4758e6a11a5c42320344f4139689b.zip
net-misc/fatrat: Fix build with Qt 5.15, EAPI-7 bump, cmake.eclass
Drop superfluous vcs-snapshot.eclass Thanks-to: Zamarin Arthur <arthurzam@gmail.com> Closes: https://bugs.gentoo.org/727166 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-misc/fatrat')
-rw-r--r--net-misc/fatrat/fatrat-1.2.0_beta2_p20161204.ebuild24
-rw-r--r--net-misc/fatrat/files/fatrat-1.2.0_beta2_p20161204-qt-5.15.patch12
2 files changed, 27 insertions, 9 deletions
diff --git a/net-misc/fatrat/fatrat-1.2.0_beta2_p20161204.ebuild b/net-misc/fatrat/fatrat-1.2.0_beta2_p20161204.ebuild
index 6a079aa56c89..c82928e3267c 100644
--- a/net-misc/fatrat/fatrat-1.2.0_beta2_p20161204.ebuild
+++ b/net-misc/fatrat/fatrat-1.2.0_beta2_p20161204.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
SNAPSHOT="14a1a146df76d70c44dcc38363848a5b41a364d5"
-
-inherit cmake-utils vcs-snapshot xdg-utils
+inherit cmake xdg-utils
DESCRIPTION="Qt5-based download/upload manager"
HOMEPAGE="http://fatrat.dolezel.info/"
@@ -16,6 +15,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="bittorrent +curl doc nls xmpp"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
RDEPEND="
dev-qt/qtcore:5
dev-qt/qtdbus:5
@@ -34,12 +38,14 @@ RDEPEND="
"
DEPEND="${RDEPEND}
dev-libs/boost
- dev-qt/linguist-tools:5
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
"
-PATCHES=( "${FILESDIR}/${PN}-1.2.0_beta2_p20150803-build.patch" )
+S="${WORKDIR}/LubosD-${PN}-14a1a14"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.2.0_beta2_p20150803-build.patch"
+ "${FILESDIR}/${P}-qt-5.15.patch"
+)
src_configure() {
local mycmakeargs=(
@@ -50,7 +56,7 @@ src_configure() {
-DWITH_JABBER="$(usex xmpp ON OFF)"
-DWITH_WEBINTERFACE=OFF
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_postinst() {
diff --git a/net-misc/fatrat/files/fatrat-1.2.0_beta2_p20161204-qt-5.15.patch b/net-misc/fatrat/files/fatrat-1.2.0_beta2_p20161204-qt-5.15.patch
new file mode 100644
index 000000000000..def09bbd7673
--- /dev/null
+++ b/net-misc/fatrat/files/fatrat-1.2.0_beta2_p20161204-qt-5.15.patch
@@ -0,0 +1,12 @@
+diff --git a/src/util/BalloonTip.cpp b/src/util/BalloonTip.cpp
+index c20c0ee..67b5284 100644
+--- a/src/util/BalloonTip.cpp
++++ b/src/util/BalloonTip.cpp
+@@ -2,6 +2,7 @@
+ * Based on Qt source code
+ */
+
++#include <QPainterPath>
+ #include "BalloonTip.h"
+ #include <QLabel>
+ #include <QPushButton>