summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/geomyidae
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/geomyidae')
-rw-r--r--net-misc/geomyidae/Manifest2
-rw-r--r--net-misc/geomyidae/geomyidae-0.26.2.ebuild50
-rw-r--r--net-misc/geomyidae/geomyidae-0.26.3.ebuild50
-rw-r--r--net-misc/geomyidae/metadata.xml8
4 files changed, 110 insertions, 0 deletions
diff --git a/net-misc/geomyidae/Manifest b/net-misc/geomyidae/Manifest
new file mode 100644
index 000000000000..f9c6fcddbffa
--- /dev/null
+++ b/net-misc/geomyidae/Manifest
@@ -0,0 +1,2 @@
+DIST geomyidae-0.26.2.tar.gz 15399 SHA256 49b4fbc437321e31a3b073cf8b88ddd4482b35a144a4289b4849e2242b991465 SHA512 337665350ee9fc09a88c83ebc8dd8d53ead9c5542c90c23f519bc99c1a1055e4751e78dbb70578325ba42d9aa59adcbbf4e32629fc75744b70e7ddc4c8266dce WHIRLPOOL 9e2409c7f5d5be2b46e43908db065a56db2e488b0769415cce9fb4b828d0f213a836e48068812d2e7aa9ee7cfd00d1970e04c504e18e9186b573e275a0c0ae2e
+DIST geomyidae-0.26.3.tar.gz 15556 SHA256 162f55ab059ab0a9be8e840497795293bbd51c34b1f4564dcdf3f0ddd5c0db31 SHA512 fcee0133547881f6df173a24eac0fd3007436365375f11c572c50cf2e77c2033d441209f7f20dab1d291b0e9305de245da409351a02df4ca92d7b158768424b3 WHIRLPOOL 79385698ddd1c9c99fbb03c77ac6e817e157e3d8779f9929fe5ae281472bbc00eec81a18b2fe02c27fd96377e6b20e5e2d0b18d9bb747a3004aa96db076bcaf3
diff --git a/net-misc/geomyidae/geomyidae-0.26.2.ebuild b/net-misc/geomyidae/geomyidae-0.26.2.ebuild
new file mode 100644
index 000000000000..28bae725699b
--- /dev/null
+++ b/net-misc/geomyidae/geomyidae-0.26.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs user
+
+DESCRIPTION="A daemon to serve the gopher protocol"
+HOMEPAGE="http://r-36.net/src/geomyidae/"
+SRC_URI="http://r-36.net/src/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+pkg_setup(){
+ enewgroup gopherd
+ enewuser gopherd -1 -1 /var/gopher gopherd
+}
+
+src_prepare() {
+ # enable verbose build
+ # drop -O. from CFLAGS
+ sed -i \
+ -e 's/@${CC}/${CC}/g' \
+ -e '/CFLAGS/s/-O. //' \
+ Makefile || die 'sed on Makefile failed'
+
+ epatch_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dosbin ${PN}
+
+ newinitd rc.d/Gentoo.init.d ${PN}
+ newconfd rc.d/Gentoo.conf.d ${PN}
+
+ insinto /var/gopher
+ doins index.gph
+ fowners -R root.gopherd /var/gopher
+ fperms -R g=rX,o=rX /var/gopher
+
+ doman ${PN}.8
+ dodoc CGI README
+}
diff --git a/net-misc/geomyidae/geomyidae-0.26.3.ebuild b/net-misc/geomyidae/geomyidae-0.26.3.ebuild
new file mode 100644
index 000000000000..28bae725699b
--- /dev/null
+++ b/net-misc/geomyidae/geomyidae-0.26.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs user
+
+DESCRIPTION="A daemon to serve the gopher protocol"
+HOMEPAGE="http://r-36.net/src/geomyidae/"
+SRC_URI="http://r-36.net/src/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+pkg_setup(){
+ enewgroup gopherd
+ enewuser gopherd -1 -1 /var/gopher gopherd
+}
+
+src_prepare() {
+ # enable verbose build
+ # drop -O. from CFLAGS
+ sed -i \
+ -e 's/@${CC}/${CC}/g' \
+ -e '/CFLAGS/s/-O. //' \
+ Makefile || die 'sed on Makefile failed'
+
+ epatch_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dosbin ${PN}
+
+ newinitd rc.d/Gentoo.init.d ${PN}
+ newconfd rc.d/Gentoo.conf.d ${PN}
+
+ insinto /var/gopher
+ doins index.gph
+ fowners -R root.gopherd /var/gopher
+ fperms -R g=rX,o=rX /var/gopher
+
+ doman ${PN}.8
+ dodoc CGI README
+}
diff --git a/net-misc/geomyidae/metadata.xml b/net-misc/geomyidae/metadata.xml
new file mode 100644
index 000000000000..b6b8956cde34
--- /dev/null
+++ b/net-misc/geomyidae/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+</pkgmetadata>