summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/hotot
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/hotot')
-rw-r--r--net-misc/hotot/Manifest2
-rw-r--r--net-misc/hotot/hotot-0.9.8.14.ebuild66
-rw-r--r--net-misc/hotot/hotot-0.9.8.14_p20130514.ebuild67
-rw-r--r--net-misc/hotot/hotot-9999.ebuild66
-rw-r--r--net-misc/hotot/metadata.xml9
5 files changed, 210 insertions, 0 deletions
diff --git a/net-misc/hotot/Manifest b/net-misc/hotot/Manifest
new file mode 100644
index 000000000000..64c0c5b870fb
--- /dev/null
+++ b/net-misc/hotot/Manifest
@@ -0,0 +1,2 @@
+DIST hotot-0.9.8.14.tar.gz 1234004 SHA256 1e67a8c39cfe250ed86633f9aedf366d25fe8133cca98fb0f28b9c1a0d7edd7b SHA512 96e110acfff50048d404e79e5345be16d85dde55f6ed952610e75cff248f78087f832dffba45302840d7fc737bb53e9642fbd44d93473713811cd402c0ca7456 WHIRLPOOL 50aa12a82f0c524d1e3dc76f74f30bcc5cd2879bef252aed6d81cf81f3cab70f4fcc09f4518f8c9c6566b6c7340b20bdeb264cbc81dcd1de915952e545510151
+DIST hotot-0.9.8.14_p20130514.tar.gz 1234379 SHA256 46198319c76516354b38fb6f02994e57ab39bf0707f533243c5c0753cde8d641 SHA512 3b4e041ebf48c7397c78139d2e8542178bf16a0bd73de8ea33781ba581b1ea3da9aefa3aa1d0bc91d32d46dd3f15902786982ef8ec64e548723cd4500386afae WHIRLPOOL e94e5eec52147fbf533858095dcc9924d381529a59c6e6d420fd06e1de50e62147660c5c0b9acf93a64efa4cdeea4c09a10303ac25e198f1709772bfcb417a0e
diff --git a/net-misc/hotot/hotot-0.9.8.14.ebuild b/net-misc/hotot/hotot-0.9.8.14.ebuild
new file mode 100644
index 000000000000..a6ad8b9193f5
--- /dev/null
+++ b/net-misc/hotot/hotot-0.9.8.14.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1 vcs-snapshot
+
+DESCRIPTION="lightweight & open source microblogging client"
+HOMEPAGE="http://hotot.org"
+SRC_URI="https://github.com/lyricat/Hotot/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="chrome gtk kde qt4"
+
+REQUIRED_USE="|| ( chrome gtk qt4 ) ${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ gtk? ( dev-python/pywebkitgtk )
+ qt4? ( dev-qt/qtwebkit:4
+ kde? ( kde-base/kdelibs ) )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ qt4? ( dev-qt/qtsql:4 )"
+
+pkg_setup() {
+ if ! use gtk ; then
+ if ! use qt4 ; then
+ ewarn "neither gtk not qt4 binaries will be build"
+ fi
+ fi
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ mycmakeargs=(
+ ${mycmakeargs}
+ $(cmake-utils_use_with chrome CHROME)
+ $(cmake-utils_use_with gtk GTK)
+ $(cmake-utils_use_with gtk GTK2)
+ -DWITH_GTK3=OFF
+ $(cmake-utils_use_with kde KDE)
+ $(cmake-utils_use_with qt4 QT)
+ -DPYTHON_EXECUTABLE=${PYTHON} )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ find "${D}" -name "*.pyc" -delete
+}
+
+pkg_postinst() {
+ if use chrome; then
+ elog "TO install hotot for chrome, open chromium/google-chrome,"
+ elog "vist chrome://chrome/extensions/ and load /usr/share/hotot"
+ elog "as unpacked extension."
+ fi
+}
diff --git a/net-misc/hotot/hotot-0.9.8.14_p20130514.ebuild b/net-misc/hotot/hotot-0.9.8.14_p20130514.ebuild
new file mode 100644
index 000000000000..3f85cc516257
--- /dev/null
+++ b/net-misc/hotot/hotot-0.9.8.14_p20130514.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1 vcs-snapshot
+
+DESCRIPTION="lightweight & open source microblogging client"
+HOMEPAGE="http://hotot.org"
+SRC_URI="https://github.com/lyricat/Hotot/tarball/ed2ff013 -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="chrome gtk kde qt4"
+
+REQUIRED_USE="|| ( chrome gtk qt4 ) ${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ gtk? ( dev-python/pywebkitgtk[${PYTHON_USEDEP}] )
+ qt4? ( dev-qt/qtwebkit:4
+ kde? ( kde-base/kdelibs ) )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ qt4? ( dev-qt/qtsql:4 )"
+
+pkg_setup() {
+ if ! use gtk ; then
+ if ! use qt4 ; then
+ ewarn "neither gtk not qt4 binaries will be build"
+ fi
+ fi
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ mycmakeargs=(
+ ${mycmakeargs}
+ $(cmake-utils_use_with chrome CHROME)
+ $(cmake-utils_use_with gtk GTK)
+ $(cmake-utils_use_with gtk GTK2)
+ -DWITH_GTK3=OFF
+ $(cmake-utils_use_with kde KDE)
+ $(cmake-utils_use_with qt4 QT)
+ -DPYTHON_EXECUTABLE=${PYTHON} )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use gtk && dosym hotot-gtk2 /usr/bin/hotot
+
+ find "${D}" -name "*.pyc" -print -delete
+}
+
+pkg_postinst() {
+ if use chrome; then
+ elog "TO install hotot for chrome, open chromium/google-chrome,"
+ elog "vist chrome://chrome/extensions/ and load /usr/share/hotot"
+ elog "as unpacked extension."
+ fi
+}
diff --git a/net-misc/hotot/hotot-9999.ebuild b/net-misc/hotot/hotot-9999.ebuild
new file mode 100644
index 000000000000..4bb51e0393cb
--- /dev/null
+++ b/net-misc/hotot/hotot-9999.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils git-2 python-single-r1
+
+DESCRIPTION="lightweight & open source microblogging client"
+HOMEPAGE="http://hotot.org"
+EGIT_REPO_URI="git://github.com/lyricat/Hotot.git"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="chrome gtk kde qt4"
+
+REQUIRED_USE="|| ( chrome gtk qt4 ) ${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ gtk? ( dev-python/pywebkitgtk[${PYTHON_USEDEP}] )
+ qt4? ( dev-qt/qtwebkit:4
+ kde? ( kde-base/kdelibs ) )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ qt4? ( dev-qt/qtsql:4 )"
+
+pkg_setup() {
+ if ! use gtk ; then
+ if ! use qt4 ; then
+ ewarn "neither gtk not qt4 binaries will be build"
+ fi
+ fi
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ mycmakeargs=(
+ ${mycmakeargs}
+ $(cmake-utils_use_with chrome CHROME)
+ $(cmake-utils_use_with gtk GTK)
+ $(cmake-utils_use_with gtk GTK2)
+ -DWITH_GTK3=OFF
+ $(cmake-utils_use_with kde KDE)
+ $(cmake-utils_use_with qt4 QT)
+ -DPYTHON_EXECUTABLE=${PYTHON} )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ find "${D}" -name "*.pyc" -delete
+}
+
+pkg_postinst() {
+ if use chrome; then
+ elog "TO install hotot for chrome, open chromium/google-chrome,"
+ elog "vist chrome://chrome/extensions/ and load /usr/share/hotot"
+ elog "as unpacked extension."
+ fi
+}
diff --git a/net-misc/hotot/metadata.xml b/net-misc/hotot/metadata.xml
new file mode 100644
index 000000000000..a518f0d15322
--- /dev/null
+++ b/net-misc/hotot/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+<use><flag name="chrome">Build chrome browser extension</flag></use>
+</pkgmetadata>