summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-02-01 17:45:52 +0100
committerMichael Weber <xmw@gentoo.org>2017-02-01 17:46:07 +0100
commitbaf04de9ddb3f88c264b88978c3249e501d7d44a (patch)
tree6d682a824288b5e1449309031dc2332f22eaf903 /net-misc/hotot
parentnet-misc/hotot: Update live ebuild to enable building qt5 and gtk3 versions. (diff)
downloadgentoo-baf04de9ddb3f88c264b88978c3249e501d7d44a.tar.gz
gentoo-baf04de9ddb3f88c264b88978c3249e501d7d44a.tar.bz2
gentoo-baf04de9ddb3f88c264b88978c3249e501d7d44a.zip
net-misc/hotot: Version bump to the last commit.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-misc/hotot')
-rw-r--r--net-misc/hotot/Manifest1
-rw-r--r--net-misc/hotot/hotot-0.9.8.15_p20150812.ebuild71
-rw-r--r--net-misc/hotot/hotot-9999.ebuild16
3 files changed, 80 insertions, 8 deletions
diff --git a/net-misc/hotot/Manifest b/net-misc/hotot/Manifest
index 0b1d8a208354..14407c778a8b 100644
--- a/net-misc/hotot/Manifest
+++ b/net-misc/hotot/Manifest
@@ -1 +1,2 @@
DIST hotot-0.9.8.14_p20130514.tar.gz 1234379 SHA256 46198319c76516354b38fb6f02994e57ab39bf0707f533243c5c0753cde8d641 SHA512 3b4e041ebf48c7397c78139d2e8542178bf16a0bd73de8ea33781ba581b1ea3da9aefa3aa1d0bc91d32d46dd3f15902786982ef8ec64e548723cd4500386afae WHIRLPOOL e94e5eec52147fbf533858095dcc9924d381529a59c6e6d420fd06e1de50e62147660c5c0b9acf93a64efa4cdeea4c09a10303ac25e198f1709772bfcb417a0e
+DIST hotot-0.9.8.15_p20150812.tar.gz 1234481 SHA256 e79de77c6176e7af045cecbd787ab8ee5da7a7d779d7b866b7fd5bd8e40b1407 SHA512 8faffd583bc7bc2888acac5b33cf7ede285a5732c7349e9f84acf63788a9a96d6c0de0759605afcacb618d904f1a54e50581684d49bd637acd6036046f28bc7e WHIRLPOOL 7f4f005e745228495f0c0248868d6720a6420eb5c211c84d89a1210ccc7316039f2fa219b1af28cd6ba7ca1d9b9111f1b7585290217c699ff94227aedef73f09
diff --git a/net-misc/hotot/hotot-0.9.8.15_p20150812.ebuild b/net-misc/hotot/hotot-0.9.8.15_p20150812.ebuild
new file mode 100644
index 000000000000..193436d38dec
--- /dev/null
+++ b/net-misc/hotot/hotot-0.9.8.15_p20150812.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1 vcs-snapshot
+
+DESCRIPTION="lightweight & open source microblogging client"
+HOMEPAGE="http://hotot.org"
+SRC_URI="https://github.com/lyricat/Hotot/tarball/452fc0924a98923b -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="chrome gtk2 gtk3 kde qt4 qt5"
+
+REQUIRED_USE="|| ( chrome gtk2 gtk3 qt4 qt5 ) ${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ gtk2? ( dev-python/pywebkitgtk[${PYTHON_USEDEP}] )
+ gtk3? ( dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ net-libs/webkit-gtk:3[introspection] )
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtwebkit:4
+ kde? ( kde-frameworks/kdelibs:4 ) )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ qt4? ( dev-qt/qtsql:4 )"
+
+src_configure() {
+ mycmakeargs=(
+ ${mycmakeargs}
+ -DWITH_CHROME=$(usex chrome)
+ -DWITH_GTK=$(usex gtk2)
+ -DWITH_GTK2=$(usex gtk2)
+ -DWITH_GTK3=$(usex gtk3)
+ -DWITH_KDE=$(usex kde)
+ -DWITH_QT=$(usex qt4)
+ -DWITH_QT5=$(usex qt5)
+ -DPYTHON_EXECUTABLE=${PYTHON} )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ find "${D}" -name "*.pyc" -delete
+}
+
+pkg_postinst() {
+ if use chrome; then
+ elog "TO install hotot for chrome, open chromium/google-chrome,"
+ elog "vist chrome://chrome/extensions/ and load /usr/share/hotot"
+ elog "as unpacked extension."
+ fi
+}
diff --git a/net-misc/hotot/hotot-9999.ebuild b/net-misc/hotot/hotot-9999.ebuild
index ef84a2dc59e0..c6a5b46c2585 100644
--- a/net-misc/hotot/hotot-9999.ebuild
+++ b/net-misc/hotot/hotot-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=6
+EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -44,13 +44,13 @@ DEPEND="${RDEPEND}
src_configure() {
mycmakeargs=(
${mycmakeargs}
- $(cmake-utils_use_with chrome CHROME)
- $(cmake-utils_use_with gtk2 GTK)
- $(cmake-utils_use_with gtk2 GTK2)
- $(cmake-utils_use_with gtk3 GTK3)
- $(cmake-utils_use_with kde KDE)
- $(cmake-utils_use_with qt4 QT)
- $(cmake-utils_use_with qt5 QT5)
+ -DWITH_CHROME=$(usex chrome)
+ -DWITH_GTK=$(usex gtk2)
+ -DWITH_GTK2=$(usex gtk2)
+ -DWITH_GTK3=$(usex gtk3)
+ -DWITH_KDE=$(usex kde)
+ -DWITH_QT=$(usex qt4)
+ -DWITH_QT5=$(usex qt5)
-DPYTHON_EXECUTABLE=${PYTHON} )
cmake-utils_src_configure