summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-09-24 17:02:27 +0200
committerLars Wendler <polynomial-c@gentoo.org>2015-09-24 17:02:42 +0200
commitad43fa9c369f986c4067175aefb88c048624b7ea (patch)
tree841d947feddc522adf5fb2ca06a20c0d47d339da /net-misc/htpdate/htpdate-1.1.2.ebuild
parentkde-base/libkgreeter: relax blocker. (diff)
downloadgentoo-ad43fa9c369f986c4067175aefb88c048624b7ea.tar.gz
gentoo-ad43fa9c369f986c4067175aefb88c048624b7ea.tar.bz2
gentoo-ad43fa9c369f986c4067175aefb88c048624b7ea.zip
net-misc/htpdate: Bump to version 1.1.2
Package-Manager: portage-2.2.21 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-misc/htpdate/htpdate-1.1.2.ebuild')
-rw-r--r--net-misc/htpdate/htpdate-1.1.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/htpdate/htpdate-1.1.2.ebuild b/net-misc/htpdate/htpdate-1.1.2.ebuild
new file mode 100644
index 000000000000..d70048232eea
--- /dev/null
+++ b/net-misc/htpdate/htpdate-1.1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo toolchain-funcs unpacker
+
+DESCRIPTION="Synchronize local workstation with time offered by remote webservers"
+HOMEPAGE="http://www.vervest.org/fiki/bin/view/HTP/DownloadC"
+SRC_URI="http://www.vervest.org/htp/archive/c/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND=""
+RDEPEND=""
+
+DOC_CONTENTS="If you would like to run htpdate as a daemon, set
+appropriate http servers in /etc/conf.d/htpdate!"
+
+src_prepare() {
+ # Use more standard adjtimex() to fix uClibc builds.
+ sed -i 's:ntp_adjtime:adjtimex:g' htpdate.[8c] || die
+}
+
+src_compile() {
+ emake CFLAGS="-Wall ${CFLAGS} ${LDFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ dosbin htpdate
+ doman htpdate.8
+ dodoc README Changelog
+
+ newconfd "${FILESDIR}"/htpdate.conf htpdate
+ newinitd "${FILESDIR}"/htpdate.init-r1 htpdate
+
+ readme.gentoo_create_doc
+}