summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2018-11-10 16:14:21 +0100
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-11-16 12:49:40 -0800
commitc3446a0be6be8a4770728890ad4a079fab9c092e (patch)
treeb00bfa25fdc58161c1adb29f7c11a04bdd09e89c /net-misc/httpie/httpie-1.0.2.ebuild
parentapp-accessibility/speech-dispatcher: Fix dependency on dev-python/pyxdg. (diff)
downloadgentoo-c3446a0be6be8a4770728890ad4a079fab9c092e.tar.gz
gentoo-c3446a0be6be8a4770728890ad4a079fab9c092e.tar.bz2
gentoo-c3446a0be6be8a4770728890ad4a079fab9c092e.zip
net-misc/httpie: upstream release 1.0.2
Upstream release 1.0.2. First HTTPie ebuild to support tests. Note that support for Python 3.7 had to be removed because necessary test packages are not yet available. Closes: https://github.com/gentoo/gentoo/pull/10389 Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Ralph Seichter <gentoo@seichter.de> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'net-misc/httpie/httpie-1.0.2.ebuild')
-rw-r--r--net-misc/httpie/httpie-1.0.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/httpie/httpie-1.0.2.ebuild b/net-misc/httpie/httpie-1.0.2.ebuild
new file mode 100644
index 000000000000..af224843dd8c
--- /dev/null
+++ b/net-misc/httpie/httpie-1.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Modern command line HTTP client"
+HOMEPAGE="https://httpie.org/ https://pypi.org/project/httpie/"
+SRC_URI="https://github.com/jakubroztocil/httpie/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.19.1[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp extras/httpie-completion.bash http
+ insinto /usr/share/fish/vendor_completions.d
+ newins extras/httpie-completion.fish http.fish
+ distutils-r1_python_install_all
+}