summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/identicurse/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/identicurse/files')
-rw-r--r--net-misc/identicurse/files/0.9-config_json_path.patch22
-rw-r--r--net-misc/identicurse/files/identicurse-gzipped_readme.patch15
2 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/identicurse/files/0.9-config_json_path.patch b/net-misc/identicurse/files/0.9-config_json_path.patch
new file mode 100644
index 000000000000..08f985f1eebd
--- /dev/null
+++ b/net-misc/identicurse/files/0.9-config_json_path.patch
@@ -0,0 +1,22 @@
+--- a/setup.py
++++ b/setup.py
+@@ -42,7 +42,7 @@
+
+ license="GPLv3+",
+
+- data_files=[('identicurse',['README', 'conf/config.json'])],
++ data_files=[('share/identicurse',['conf/config.json'])],
+ packages=find_packages('src'),
+ package_dir={'': 'src'},
+ include_package_data=True,
+--- a/src/identicurse/identicurse.py
++++ b/src/identicurse/identicurse.py
+@@ -156,7 +156,7 @@
+ else:
+ import getpass, time
+ # no config yet, so let's build one
+- config.config.load(os.path.join(self.path, "config.json"))
++ config.config.load(os.path.join("/", "usr", "share", "identicurse", "config.json"))
+ print "No config was found, so we will now run through a few quick questions to set up a basic config for you (which will be saved as %s so you can manually edit it later). If the default (where defaults are available, they're stated in []) is already fine for any question, just press Enter without typing anything, and the default will be used." % (config.config.filename)
+ print "This version of IdentiCurse supports OAuth login. Using OAuth to log in means that you do not need to enter your username and password."
+ use_oauth = raw_input("Use OAuth [Y/n]? ").upper()
diff --git a/net-misc/identicurse/files/identicurse-gzipped_readme.patch b/net-misc/identicurse/files/identicurse-gzipped_readme.patch
new file mode 100644
index 000000000000..b4575ef07b97
--- /dev/null
+++ b/net-misc/identicurse/files/identicurse-gzipped_readme.patch
@@ -0,0 +1,15 @@
+Description: Point the online help to /usr/share/identicurse/README.
+Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=612976
+Author: Alessio Treglia <alessio@debian.org>
+
+--- a/src/identicurse/tabbage.py
++++ b/src/identicurse/tabbage.py
+@@ -225,6 +225,8 @@ class Help(Tab):
+ def __init__(self, window, identicurse_path):
+ self.name = "Help"
+ self.path = os.path.join(identicurse_path, "README")
++ if not os.path.isfile(self.path):
++ self.path = '/usr/share/identicurse/README'
+ Tab.__init__(self, window)
+
+ def update(self):