summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-04-29 11:29:43 +0200
committerJeroen Roovers <jer@gentoo.org>2019-04-29 11:30:41 +0200
commit1667ae22ab8e5b448221866c95cc7b60a8534cf3 (patch)
tree6d87b7fad54c3f6554b60489fa6820f022530fd5 /net-misc/iperf/iperf-2.0.14a.ebuild
parentarm/package.use.mask: Masked dev-util/geany-plugins[markdown] (diff)
downloadgentoo-1667ae22ab8e5b448221866c95cc7b60a8534cf3.tar.gz
gentoo-1667ae22ab8e5b448221866c95cc7b60a8534cf3.tar.bz2
gentoo-1667ae22ab8e5b448221866c95cc7b60a8534cf3.zip
net-misc/iperf: Version 2.0.14a
Package-Manager: Portage-2.3.65, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-misc/iperf/iperf-2.0.14a.ebuild')
-rw-r--r--net-misc/iperf/iperf-2.0.14a.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/iperf/iperf-2.0.14a.ebuild b/net-misc/iperf/iperf-2.0.14a.ebuild
new file mode 100644
index 000000000000..b680ce3d38bb
--- /dev/null
+++ b/net-misc/iperf/iperf-2.0.14a.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Tool to measure IP bandwidth using UDP or TCP"
+HOMEPAGE="http://iperf2.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}2/${PN}-2.0.13.tar.gz"
+
+LICENSE="HPND"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint"
+IUSE="ipv6 threads debug"
+
+DOCS="INSTALL README"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.12-ipv6.patch
+ "${FILESDIR}"/${P}.patch
+)
+S=${WORKDIR}/${PN}-2.0.13
+
+src_configure() {
+ econf \
+ $(use_enable debug debuginfo) \
+ $(use_enable ipv6) \
+ $(use_enable threads)
+}
+
+src_install() {
+ default
+ dodoc doc/*
+ newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}