summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2020-09-04 20:24:42 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-09-20 16:38:18 +0200
commit5fad00b8d194ef886e0a4985402272f6176c7ec6 (patch)
tree02bdff7b9dff10810f1b0933dcd4d4eb98ef7ea3 /net-misc/iputils
parentsys-process/htop: remove unused patch (diff)
downloadgentoo-5fad00b8d194ef886e0a4985402272f6176c7ec6.tar.gz
gentoo-5fad00b8d194ef886e0a4985402272f6176c7ec6.tar.bz2
gentoo-5fad00b8d194ef886e0a4985402272f6176c7ec6.zip
net-misc/iputils: remove unused patches
Closes: https://github.com/gentoo/gentoo/pull/17417 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-misc/iputils')
-rw-r--r--net-misc/iputils/files/iputils-20180629-fix-ping-on-musl.patch54
-rw-r--r--net-misc/iputils/files/iputils-20180629-musl.patch87
-rw-r--r--net-misc/iputils/files/iputils-20190515-fix-setcap.patch67
-rw-r--r--net-misc/iputils/files/rarpd.conf.d8
-rw-r--r--net-misc/iputils/files/rarpd.init.d19
5 files changed, 0 insertions, 235 deletions
diff --git a/net-misc/iputils/files/iputils-20180629-fix-ping-on-musl.patch b/net-misc/iputils/files/iputils-20180629-fix-ping-on-musl.patch
deleted file mode 100644
index 8d8160a3d4af..000000000000
--- a/net-misc/iputils/files/iputils-20180629-fix-ping-on-musl.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From 25899e849aa3abc1ad29ebf0b830262a859eaed5 Mon Sep 17 00:00:00 2001
-From: Petr Vorel <petr.vorel@gmail.com>
-Date: Sat, 21 Jul 2018 17:46:14 +0200
-Subject: [PATCH] ping: Fix AI_CANONIDN usage on some systems
-
-Commit 99f67db used AI_CANONIDN in a way, which broke compilation on
-systems where AI_CANONIDN is not defined in netdb.h (e.g. glibc < 2.3.4,
-alternative libcs that don't support IDN: e.g. current musl 1.1.19 and
-uClibc-ng 1.0.30) when not using the system libidn2.
-
-Fixes: 99f67db ping: Fix ping name encoded using ACE on C locale
-
-Reported-by: Nicholas Fish
-Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
----
- ping.c | 2 +-
- ping.h | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/ping.c b/ping.c
-index 733477f..b241815 100644
---- a/ping.c
-+++ b/ping.c
-@@ -207,9 +207,9 @@ main(int argc, char **argv)
-
- #ifdef USE_IDN
- setlocale(LC_ALL, "");
--#endif
- if (!strcmp(setlocale(LC_ALL, NULL), "C"))
- hints.ai_flags &= ~ AI_CANONIDN;
-+#endif
-
- /* Support being called using `ping4` or `ping6` symlinks */
- if (argv[0][strlen(argv[0])-1] == '4')
-diff --git a/ping.h b/ping.h
-index 3e09685..8a0c4ef 100644
---- a/ping.h
-+++ b/ping.h
-@@ -28,7 +28,6 @@
- #include <netinet/icmp6.h>
- #include <linux/filter.h>
- #include <resolv.h>
--#include <locale.h>
-
- #ifdef CAPABILITIES
- #include <sys/prctl.h>
-@@ -36,6 +35,7 @@
- #endif
-
- #ifdef USE_IDN
-+#include <locale.h>
- #include <idn2.h>
- #define getaddrinfo_flags (AI_CANONNAME | AI_IDN | AI_CANONIDN)
- #define getnameinfo_flags NI_IDN
diff --git a/net-misc/iputils/files/iputils-20180629-musl.patch b/net-misc/iputils/files/iputils-20180629-musl.patch
deleted file mode 100644
index 48742d966021..000000000000
--- a/net-misc/iputils/files/iputils-20180629-musl.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-commit 5007d7067918fb3d950d34c01d059e5222db679a
-Author: Aric Belsito <lluixhi@gmail.com>
-AuthorDate: Mon Dec 4 00:10:29 2017 +0100
-Commit: Thomas Deutschmann <whissi@gentoo.org>
-CommitDate: Wed Jul 11 01:33:28 2018 +0200
-
- Fix build on MUSL
-
- Add missing AI_IDN and NI_IDN declarations.
-
- Bug: https://bugs.gentoo.org/503914
- Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-
-diff --git a/arping.c b/arping.c
-index c2f2129..d753345 100644
---- a/arping.c
-+++ b/arping.c
-@@ -44,6 +44,13 @@
-
- #ifdef USE_IDN
- #include <locale.h>
-+
-+#ifndef AI_IDN
-+#define AI_IDN 0x0040
-+#endif
-+#ifndef AI_CANONIDN
-+#define AI_CANONIDN 0x0080
-+#endif
- #endif
-
- #include "SNAPSHOT.h"
-diff --git a/ping.h b/ping.h
-index 3e09685..1e51c67 100644
---- a/ping.h
-+++ b/ping.h
-@@ -37,6 +37,17 @@
-
- #ifdef USE_IDN
- #include <idn2.h>
-+
-+#ifndef AI_IDN
-+#define AI_IDN 0x0040
-+#endif
-+#ifndef AI_CANONIDN
-+#define AI_CANONIDN 0x0080
-+#endif
-+#ifndef NI_IDN
-+#define NI_IDN 32
-+#endif
-+
- #define getaddrinfo_flags (AI_CANONNAME | AI_IDN | AI_CANONIDN)
- #define getnameinfo_flags NI_IDN
- #else
-diff --git a/tracepath.c b/tracepath.c
-index 53bda16..9558e49 100644
---- a/tracepath.c
-+++ b/tracepath.c
-@@ -29,6 +29,14 @@
-
- #ifdef USE_IDN
- #include <locale.h>
-+
-+#ifndef AI_IDN
-+#define AI_IDN 0x0040
-+#endif
-+#ifndef NI_IDN
-+#define NI_IDN 32
-+#endif
-+
- #define getnameinfo_flags NI_IDN
- #else
- #define getnameinfo_flags 0
-diff --git a/traceroute6.c b/traceroute6.c
-index a1022f9..ab34615 100644
---- a/traceroute6.c
-+++ b/traceroute6.c
-@@ -246,6 +246,10 @@
- #ifdef USE_IDN
- #include <locale.h>
-
-+#ifndef NI_IDN
-+#define NI_IDN 32
-+#endif
-+
- #define ADDRINFO_IDN_FLAGS AI_IDN
- #define getnameinfo_flags NI_IDN
- #else
diff --git a/net-misc/iputils/files/iputils-20190515-fix-setcap.patch b/net-misc/iputils/files/iputils-20190515-fix-setcap.patch
deleted file mode 100644
index 6e9c7c6a8354..000000000000
--- a/net-misc/iputils/files/iputils-20190515-fix-setcap.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From 473be6467f995865244e7e68b2fa587a4ee79551 Mon Sep 17 00:00:00 2001
-From: Michael Weiss <dev.primeos@gmail.com>
-Date: Thu, 16 May 2019 09:44:27 +0000
-Subject: [PATCH] build-sys: Make setcap really optional
-
-The setcap dependency is marked as optional but meson.build depends on
-setcap.path():
-
-meson.build:246:7: ERROR: add_install_script args must be strings
----
- meson.build | 11 +++++++----
- 1 file changed, 7 insertions(+), 4 deletions(-)
-
-diff --git a/meson.build b/meson.build
-index 8af9e18..95c778a 100644
---- a/meson.build
-+++ b/meson.build
-@@ -221,10 +221,13 @@ config_h = configure_file(
- setcap = find_program('setcap', '/usr/sbin/setcap', '/sbin/setcap', required : false)
- if get_option('NO_SETCAP_OR_SUID')
- perm_type = 'none'
-+ setcap_path = '/dev/null'
- elif cap_dep.found() and setcap.found()
- perm_type = 'caps'
-+ setcap_path = setcap.path()
- else
- perm_type = 'setuid'
-+ setcap_path = '/dev/null'
- endif
-
- ############################################################
-@@ -243,7 +246,7 @@ if build_ping == true
- join_paths(get_option('prefix'), get_option('bindir')),
- 'ping',
- perm_type,
-- setcap.path()
-+ setcap_path
- )
- endif
-
-@@ -263,7 +266,7 @@ if build_traceroute6 == true
- join_paths(get_option('prefix'), get_option('bindir')),
- 'traceroute6',
- perm_type,
-- setcap.path()
-+ setcap_path
- )
- endif
-
-@@ -276,7 +279,7 @@ if build_clockdiff == true
- join_paths(get_option('prefix'), get_option('bindir')),
- 'clockdiff',
- perm_type,
-- setcap.path()
-+ setcap_path
- )
- endif
-
-@@ -306,7 +309,7 @@ if build_arping == true
- join_paths(get_option('prefix'), get_option('bindir')),
- 'arping',
- perm_type,
-- setcap.path()
-+ setcap_path
- )
- endif
-
diff --git a/net-misc/iputils/files/rarpd.conf.d b/net-misc/iputils/files/rarpd.conf.d
deleted file mode 100644
index ef7fc48e17bf..000000000000
--- a/net-misc/iputils/files/rarpd.conf.d
+++ /dev/null
@@ -1,8 +0,0 @@
-# Config file for /etc/init.d/rarpd
-
-# You probably want to select the interface for this to listen on.
-# By default it uses loopback which most likely won't help.
-RARPD_IFACE="lo"
-
-# See the rarpd(8) manpage for more info.
-RARPD_OPTS="-b /tftpboot"
diff --git a/net-misc/iputils/files/rarpd.init.d b/net-misc/iputils/files/rarpd.init.d
deleted file mode 100644
index 27081fc760c0..000000000000
--- a/net-misc/iputils/files/rarpd.init.d
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-pidfile="/var/run/rarpd.pid"
-command="/usr/sbin/rarpd"
-# The -d option keeps it from forking. This way s-s-d can do the fork and
-# set up the pidfile with the right value below.
-command_args="-d ${RARPD_OPTS} ${RARPD_IFACE}"
-start_stop_daemon_args="--background --make-pidfile"
-
-start_pre() {
- if [ ! -f /etc/ethers ] ; then
- eerror "Please create /etc/ethers with the following content:"
- eerror "[MAC address] [name or IP]"
- return 1
- fi
- return 0
-}