summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/ipx-utils/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/ipx-utils/files')
-rw-r--r--net-misc/ipx-utils/files/ipx-utils-1.1-makefile.patch24
-rw-r--r--net-misc/ipx-utils/files/ipx-utils-1.1-proc.patch13
-rw-r--r--net-misc/ipx-utils/files/ipx.confd27
-rw-r--r--net-misc/ipx-utils/files/ipx.init43
4 files changed, 107 insertions, 0 deletions
diff --git a/net-misc/ipx-utils/files/ipx-utils-1.1-makefile.patch b/net-misc/ipx-utils/files/ipx-utils-1.1-makefile.patch
new file mode 100644
index 000000000000..5a596f818d19
--- /dev/null
+++ b/net-misc/ipx-utils/files/ipx-utils-1.1-makefile.patch
@@ -0,0 +1,24 @@
+--- ipx-1.1.orig/Makefile
++++ ipx-1.1/Makefile
+@@ -10,17 +10,8 @@ clean:
+ install: $(UTILS)
+ for i in $(UTILS); \
+ do \
+- install --strip $$i /sbin; \
+- install $$i.8 /usr/man/man8; \
++ install $$i ${DESTDIR}/sbin; \
++ install $$i.8 ${DESTDIR}/usr/share/man/man8; \
+ done
+- install init.ipx /etc/rc.d/init.d/ipx
+- install -m 0644 config.ipx /etc/sysconfig/ipx
+- rm -f /etc/rc.d/rc2.d/S15ipx
+- ln -sf /etc/rc.d/init.d/ipx /etc/rc.d/rc2.d/S15ipx
+- rm -f /etc/rc.d/rc3.d/S15ipx
+- ln -sf /etc/rc.d/init.d/ipx /etc/rc.d/rc3.d/S15ipx
+- rm -f /etc/rc.d/rc5.d/S15ipx
+- ln -sf /etc/rc.d/init.d/ipx /etc/rc.d/rc5.d/S15ipx
+- rm -f /etc/rc.d/rc6.d/K55ipx
+- ln -sf /etc/rc.d/init.d/ipx /etc/rc.d/rc6.d/K55ipx
+-
++# install init.ipx /etc/rc.d/init.d/ipx
++# install -m 0644 config.ipx /etc/sysconfig/ipx
diff --git a/net-misc/ipx-utils/files/ipx-utils-1.1-proc.patch b/net-misc/ipx-utils/files/ipx-utils-1.1-proc.patch
new file mode 100644
index 000000000000..d82d228ff139
--- /dev/null
+++ b/net-misc/ipx-utils/files/ipx-utils-1.1-proc.patch
@@ -0,0 +1,13 @@
+--- ipx-1.1/ipx_interface.c.orig 2004-10-16 13:14:40.677964152 -0400
++++ ipx-1.1/ipx_interface.c 2004-10-16 13:15:18.464219768 -0400
+@@ -191,7 +191,9 @@
+ exit(-1);
+ }
+
+- fp = fopen("/proc/net/ipx_interface", "r");
++ fp = fopen("/proc/net/ipx/interface", "r");
++ if (fp == NULL)
++ fp = fopen("/proc/net/ipx_interface", "r");
+ if (fp == NULL) {
+ fprintf(stderr,
+ "%s: Unable to open \"/proc/net/ipx_interface.\"\n",
diff --git a/net-misc/ipx-utils/files/ipx.confd b/net-misc/ipx-utils/files/ipx.confd
new file mode 100644
index 000000000000..d061d0d0de83
--- /dev/null
+++ b/net-misc/ipx-utils/files/ipx.confd
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Config file for /etc/init.d/ipx
+
+# Automatically selecting a primary interface.
+IPX_AUTO_PRIMARY=on
+
+# Automatically creating interfaces.
+IPX_AUTO_INTERFACE=on
+
+# Interface to which IPX sockets are bound.
+IPX_DEVICE=eth0
+
+# The IPX frame type to use
+IPX_FRAME=802.2
+
+# Create a special kind of IPX interface that does not
+# have a physical device or frame type.
+IPX_INTERNAL_NET=no
+
+# Network number
+IPX_NETNUM=1
+
+# Node number
+IPX_NODENUM=1
diff --git a/net-misc/ipx-utils/files/ipx.init b/net-misc/ipx-utils/files/ipx.init
new file mode 100644
index 000000000000..091c9d8de706
--- /dev/null
+++ b/net-misc/ipx-utils/files/ipx.init
@@ -0,0 +1,43 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+#NB: Config is in /etc/conf.d/ipx
+
+depend() {
+ use net
+}
+
+start() {
+ local retval=0
+
+ ebegin "Bringing IPX up"
+ if [ ${IPX_INTERNAL_NET} = "yes" ]
+ then
+ /sbin/ipx_internal_net add ${IPX_NETNUM} ${IPX_NODENUM}
+ retval=$?
+ else
+ /sbin/ipx_interface add -p ${IPX_DEVICE} \
+ ${IPX_FRAME} ${IPX_NETNUM}
+ retval=$?
+ fi
+
+ ipx_configure \
+ --auto_primary=${IPX_AUTO_PRIMARY} \
+ --auto_interface=${IPX_AUTO_INTERFACE}
+ retval=$(( $retval + $? ))
+ eend ${retval} "Failed to bring IPX up"
+}
+
+stop() {
+ local retval=0
+
+ ebegin "Bringing IPX down"
+ /bin/umount -v -a -tncpfs
+ /sbin/ipx_configure --auto_primary=off --auto_interface=off
+ retval=$?
+ /sbin/ipx_interface delall
+ retval=$(( $retval + $? ))
+ eend ${retval} "Failed to down IPX"
+}