summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-05-03 18:51:28 -0500
committerAustin English <wizardedit@gentoo.org>2016-05-03 19:08:37 -0500
commit685d54c17656ee261837ba37a86aea7d6fee76cc (patch)
tree1c018c9adae4df366237ae28c2e79a38eb7e4117 /net-misc/ipx-utils/ipx-utils-1.1-r4.ebuild
parentnet-misc/igmpproxy: remove old version (diff)
downloadgentoo-685d54c17656ee261837ba37a86aea7d6fee76cc.tar.gz
gentoo-685d54c17656ee261837ba37a86aea7d6fee76cc.tar.bz2
gentoo-685d54c17656ee261837ba37a86aea7d6fee76cc.zip
net-misc/ipx-utils: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc/ipx-utils/ipx-utils-1.1-r4.ebuild')
-rw-r--r--net-misc/ipx-utils/ipx-utils-1.1-r4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/ipx-utils/ipx-utils-1.1-r4.ebuild b/net-misc/ipx-utils/ipx-utils-1.1-r4.ebuild
new file mode 100644
index 000000000000..fbf7d50af696
--- /dev/null
+++ b/net-misc/ipx-utils/ipx-utils-1.1-r4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+inherit eutils
+
+DESCRIPTION="The IPX Utilities"
+HOMEPAGE="ftp://sunsite.unc.edu/pub/Linux/system/filesystems/ncpfs/"
+SRC_URI="ftp://sunsite.unc.edu/pub/Linux/system/filesystems/ncpfs/${P/-utils}.tar.gz"
+
+LICENSE="ipx-utils GPL-2" # GPL-2 only for init script
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/${P/-utils}
+
+src_prepare() {
+ sed -i "s:-O2 -Wall:${CFLAGS}:" "${S}"/Makefile
+ eapply "${FILESDIR}"/${P}-makefile.patch
+ eapply "${FILESDIR}"/${P}-proc.patch #67642
+
+ default
+}
+
+src_install() {
+ doman *.8
+ newconfd "${FILESDIR}"/ipx.confd ipx
+ newinitd "${FILESDIR}"/ipx.init ipx
+
+ default
+}