summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-04-25 17:49:44 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-04-25 17:49:44 +0200
commitb6c0516df27cbc2c145e278397ff0370ab131a67 (patch)
tree69a0e182a764a3e44ac69870291a09b643e57e15 /net-misc/kafkacat/kafkacat-1.3.1.ebuild
parentkde-misc/plasma-applet-redshift-control: Version bump to 1.0.18 (diff)
downloadgentoo-b6c0516df27cbc2c145e278397ff0370ab131a67.tar.gz
gentoo-b6c0516df27cbc2c145e278397ff0370ab131a67.tar.bz2
gentoo-b6c0516df27cbc2c145e278397ff0370ab131a67.zip
net-misc/kafkacat: Initial commit
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-misc/kafkacat/kafkacat-1.3.1.ebuild')
-rw-r--r--net-misc/kafkacat/kafkacat-1.3.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-misc/kafkacat/kafkacat-1.3.1.ebuild b/net-misc/kafkacat/kafkacat-1.3.1.ebuild
new file mode 100644
index 000000000000..607a27250bd7
--- /dev/null
+++ b/net-misc/kafkacat/kafkacat-1.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Generic command line non-JVM Apache Kafka producer and consumer"
+HOMEPAGE="https://github.com/edenhill/kafkacat"
+SRC_URI="https://github.com/edenhill/kafkacat/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+json"
+
+DEPEND=">=dev-libs/librdkafka-0.9.4
+ json? ( dev-libs/yajl )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_enable json) --cc=$(tc-getCC)
+}
+
+src_install() {
+ default
+ doman ${PN}.1
+}