summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-02-27 09:20:55 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-02-27 09:59:34 +0100
commitef8cc2158d918e62810d818b11a799333b62dddb (patch)
tree9444804d69a5812a7d2558ab9907714dc6856987 /net-misc/kea/kea-9999.ebuild
parentnet-misc/kea: Bump to version 1.7.5 (diff)
downloadgentoo-ef8cc2158d918e62810d818b11a799333b62dddb.tar.gz
gentoo-ef8cc2158d918e62810d818b11a799333b62dddb.tar.bz2
gentoo-ef8cc2158d918e62810d818b11a799333b62dddb.zip
net-misc/kea: Synced live ebuild
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-misc/kea/kea-9999.ebuild')
-rw-r--r--net-misc/kea/kea-9999.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/net-misc/kea/kea-9999.ebuild b/net-misc/kea/kea-9999.ebuild
index c915fee4402e..2f6a4dc21e8a 100644
--- a/net-misc/kea/kea-9999.ebuild
+++ b/net-misc/kea/kea-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs user
+inherit toolchain-funcs
MY_PV="${PV//_p/-P}"
MY_PV="${MY_PV/_/-}"
@@ -34,7 +34,9 @@ DEPEND="
openssl? ( dev-libs/openssl:0= )
postgres? ( dev-db/postgresql:* )
"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ acct-group/dhcp
+ acct-user/dhcp"
BDEPEND="virtual/pkgconfig"
S="${WORKDIR}/${MY_P}"
@@ -69,8 +71,3 @@ src_install() {
keepdir /var/{lib,run}/${PN} /var/log
find "${ED}" -type f \( -name "*.a" -o -name "*.la" \) -delete || die
}
-
-pkg_preinst() {
- enewgroup dhcp
- enewuser dhcp -1 -1 /var/lib/dhcp dhcp
-}