summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/ksshaskpass
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/ksshaskpass')
-rw-r--r--net-misc/ksshaskpass/Manifest1
-rw-r--r--net-misc/ksshaskpass/ksshaskpass-0.5.3-r1.ebuild54
-rw-r--r--net-misc/ksshaskpass/metadata.xml5
3 files changed, 60 insertions, 0 deletions
diff --git a/net-misc/ksshaskpass/Manifest b/net-misc/ksshaskpass/Manifest
new file mode 100644
index 000000000000..e65c3cc20e59
--- /dev/null
+++ b/net-misc/ksshaskpass/Manifest
@@ -0,0 +1 @@
+DIST 50971-ksshaskpass-0.5.3.tar.gz 11010 SHA256 a3a47eba74a52ec3d9d8740ed9a29a5aa852d4e268b5d81154f85b90258a2124 SHA512 0274b58fb9dbb634688e5ee8b22a88012483907769796733c79f8e3c115463702a9cdd787d49d0b94a7942f5f88ed3465a6161d6e4516711b2bba5c47a91fa50 WHIRLPOOL d3e68640d3e0049bdd071fe72bf0bd9767bf349c94b2fbb42e7fafe6259d895ec2d5122ae9477e66073c53cbbda704ec0237328dd948b21207b2db2b39946450
diff --git a/net-misc/ksshaskpass/ksshaskpass-0.5.3-r1.ebuild b/net-misc/ksshaskpass/ksshaskpass-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..be26dd48d37e
--- /dev/null
+++ b/net-misc/ksshaskpass/ksshaskpass-0.5.3-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="http://www.kde-apps.org/content/show.php?content=50971&forumpage=0"
+SRC_URI="http://www.kde-apps.org/CONTENT/content-files/50971-${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+SLOT="4"
+IUSE="debug"
+
+RDEPEND="net-misc/openssh"
+
+CFG="ksshaskpass.sh"
+
+src_prepare() {
+ STARTUPDIR=/etc/kde/startup
+ SHUTDOWNDIR=/etc/kde/shutdown
+
+ kde4-base_src_prepare
+}
+
+src_install() {
+ kde4-base_src_install
+
+ cat <<-EOF > "${T}/${CFG}"
+export SSH_ASKPASS="${PREFIX}/bin/ksshaskpass"
+EOF
+ insinto "${STARTUPDIR}"
+ doins "${T}/${CFG}"
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ elog
+ elog "In order to have ksshagent start at kde startup,"
+ elog "edit ${STARTUPDIR}/agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in ${SHUTDOWNDIR}/agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${P} has been installed as your default askpass application in KDE4 session."
+ elog "If it's not desired, point the one you want to use in ${STARTUPDIR}/${CFG}"
+ elog
+}
diff --git a/net-misc/ksshaskpass/metadata.xml b/net-misc/ksshaskpass/metadata.xml
new file mode 100644
index 000000000000..8d1e86a9cefb
--- /dev/null
+++ b/net-misc/ksshaskpass/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>