summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/lambdamoo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/lambdamoo')
-rw-r--r--net-misc/lambdamoo/Manifest1
-rw-r--r--net-misc/lambdamoo/files/1.8.1-enable-outbound.patch13
-rw-r--r--net-misc/lambdamoo/files/lambdamoo.conf6
-rw-r--r--net-misc/lambdamoo/files/lambdamoo.rc48
-rw-r--r--net-misc/lambdamoo/lambdamoo-1.8.1-r2.ebuild47
-rw-r--r--net-misc/lambdamoo/metadata.xml10
6 files changed, 125 insertions, 0 deletions
diff --git a/net-misc/lambdamoo/Manifest b/net-misc/lambdamoo/Manifest
new file mode 100644
index 000000000000..a87c0be37566
--- /dev/null
+++ b/net-misc/lambdamoo/Manifest
@@ -0,0 +1 @@
+DIST LambdaMOO-1.8.1.tar.gz 363803 SHA256 1c404855e5db85224e4fec0667bbbb9b2a3e98ac82d49e885ddb4ce8c24f3e5a
diff --git a/net-misc/lambdamoo/files/1.8.1-enable-outbound.patch b/net-misc/lambdamoo/files/1.8.1-enable-outbound.patch
new file mode 100644
index 000000000000..b96e013683b8
--- /dev/null
+++ b/net-misc/lambdamoo/files/1.8.1-enable-outbound.patch
@@ -0,0 +1,13 @@
+diff -ur MOO-1.8.1.orig/options.h MOO-1.8.1/options.h
+--- MOO-1.8.1.orig/options.h 2003-04-17 15:25:25.000000000 -0500
++++ MOO-1.8.1/options.h 2003-04-17 15:27:33.000000000 -0500
+@@ -155,7 +155,7 @@
+ * NP_SINGLE or NP_LOCAL.
+ */
+
+-/* #define OUTBOUND_NETWORK */
++#define OUTBOUND_NETWORK
+
+ /******************************************************************************
+ * The following constants define certain aspects of the server's network
+
diff --git a/net-misc/lambdamoo/files/lambdamoo.conf b/net-misc/lambdamoo/files/lambdamoo.conf
new file mode 100644
index 000000000000..3f84faefe344
--- /dev/null
+++ b/net-misc/lambdamoo/files/lambdamoo.conf
@@ -0,0 +1,6 @@
+# The full path to your database, without the extention.
+# For example:
+DB_PREFIX=/usr/share/lambdamoo/Minimal
+
+# The port LambdaMOO should listen for incoming connections on
+PORT=7777
diff --git a/net-misc/lambdamoo/files/lambdamoo.rc b/net-misc/lambdamoo/files/lambdamoo.rc
new file mode 100644
index 000000000000..142ce15dc8a9
--- /dev/null
+++ b/net-misc/lambdamoo/files/lambdamoo.rc
@@ -0,0 +1,48 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# adapted from Pavel Curtis' restart.sh
+
+depend() {
+ need net
+}
+
+check_setup() {
+ if [ ! -r ${DB_PREFIX}.db ] ; then
+ eerror "Unable to read ${DB_PREFIX}.db"
+ return 1
+ fi
+
+ if [ -r ${DB_PREFIX}.db.new ] ; then
+ mv ${DB_PREFIX}.db ${DB_PREFIX}.db.old
+ mv ${DB_PREFIX}.db.new ${DB_PREFIX}.db
+ #Pavel compressed the old db here, I have not to save start time.
+ fi
+
+ if [ -f /var/log/lambdamoo.log ] ; then
+ cat /var/log/lambdamoo.log >> /var/log/lambdamoo.log.old
+ rm /var/log/lambdamoo.log
+ fi
+
+ return 0
+}
+
+start() {
+ check_setup || return 1
+
+ ebegin "Starting LambdaMOO"
+ echo "`date`: RESTARTED" >> ${DB_PREFIX}.log
+ start-stop-daemon --start --startas /usr/sbin/moo \
+ --pidfile /var/run/LambdaMOO.pid --make-pidfile \
+ -- -l /var/log/lambdamoo.log ${DB_PREFIX}.db ${DB_PREFIX}.db.new ${PORT} &
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping LambdaMOO"
+ start-stop-daemon -o --quiet --stop --pidfile /var/run/LambdaMOO.pid
+ eend $?
+ [ -f /var/run/LambdaMOO.pid ] && rm /var/run/LambdaMOO.pid
+}
diff --git a/net-misc/lambdamoo/lambdamoo-1.8.1-r2.ebuild b/net-misc/lambdamoo/lambdamoo-1.8.1-r2.ebuild
new file mode 100644
index 000000000000..423f46ff2c74
--- /dev/null
+++ b/net-misc/lambdamoo/lambdamoo-1.8.1-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="networked mud that can be used for different types of collaborative software"
+HOMEPAGE="http://sourceforge.net/projects/lambdamoo/"
+SRC_URI="mirror://sourceforge/lambdamoo/LambdaMOO-${PV}.tar.gz"
+
+LICENSE="LambdaMOO GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE=""
+
+DEPEND="sys-devel/bison"
+RDEPEND=""
+
+S=${WORKDIR}/MOO-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-enable-outbound.patch
+ sed -i Makefile.in \
+ -e '/ -o /s|$(CFLAGS)|& $(LDFLAGS)|g' \
+ || die "sed Makefile.in"
+ eautoreconf
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ CFLAGS="${CFLAGS} \
+ -DHAVE_MKFIFO=1" \
+ || die "emake failed!"
+}
+
+src_install() {
+ dosbin moo
+ insinto /usr/share/${PN}
+ doins Minimal.db
+ dodoc *.txt README*
+
+ newinitd "${FILESDIR}"/lambdamoo.rc ${PN}
+ newconfd "${FILESDIR}"/lambdamoo.conf ${PN}
+}
diff --git a/net-misc/lambdamoo/metadata.xml b/net-misc/lambdamoo/metadata.xml
new file mode 100644
index 000000000000..602d45342949
--- /dev/null
+++ b/net-misc/lambdamoo/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">lambdamoo</remote-id>
+ </upstream>
+</pkgmetadata>