summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/lcr/lcr-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/lcr/lcr-9999.ebuild')
-rw-r--r--net-misc/lcr/lcr-9999.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-misc/lcr/lcr-9999.ebuild b/net-misc/lcr/lcr-9999.ebuild
new file mode 100644
index 000000000000..fd6b40bedbd9
--- /dev/null
+++ b/net-misc/lcr/lcr-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit git-2 autotools
+
+DESCRIPTION="Linux Call Router"
+HOMEPAGE="http://isdn.eversberg.eu/"
+EGIT_REPO_URI="git://git.misdn.eu/lcr.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="asterisk +ssl +gsm-bs +gsm-ms ss5 +sip gsmhr misdn"
+
+DEPEND="
+ media-libs/opencore-amr
+ asterisk? ( net-misc/asterisk )
+ ssl? ( dev-libs/openssl )
+ gsm-bs? ( net-wireless/openbsc )
+ sip? ( net-libs/sofia-sip )
+ gsm-ms? ( net-wireless/osmocom-bb )
+"
+ #mdisn? ( net-misc/misdn )
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with asterisk) \
+ $(use_with ssl) \
+ $(use_with gsm-bs) \
+ $(use_with gsm-ms) \
+ $(use_with ss5) \
+ $(use_with sip) \
+ $(use_with misdn) \
+ $(use_enable gsmhr)
+}
+
+src_compile() {
+ emake -j1
+}
+
+pkg_postinst() {
+ use gsmhr || return
+ ewarn "You have enabled the gsmhr use flag, for the GSM half-rate"
+ ewarn "codec. This is strongly discouraged, except for testing,"
+ ewarn "because of extremely high CPU usage."
+}