summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-08-08 17:20:42 -0400
committerCraig Andrews <candrews@gentoo.org>2019-08-08 17:21:59 -0400
commit66186ef498235674cb9fec090604b0d7673f96db (patch)
treeb4ff0e68e36f0e36c7641ae5ea5c7ff0c8f7df65 /net-misc/libteam
parentnet-proxy/haproxy: Cleanup and version bumps (diff)
downloadgentoo-66186ef498235674cb9fec090604b0d7673f96db.tar.gz
gentoo-66186ef498235674cb9fec090604b0d7673f96db.tar.bz2
gentoo-66186ef498235674cb9fec090604b0d7673f96db.zip
net-misc/libteam: 1.29 version bump
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-misc/libteam')
-rw-r--r--net-misc/libteam/Manifest1
-rw-r--r--net-misc/libteam/libteam-1.29.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-misc/libteam/Manifest b/net-misc/libteam/Manifest
index f7a5d819e093..345e8c0bcf66 100644
--- a/net-misc/libteam/Manifest
+++ b/net-misc/libteam/Manifest
@@ -1 +1,2 @@
DIST libteam-1.22.tar.gz 544302 BLAKE2B 8c20471506546de6f45989513ed22fe79f694febacbf1a0caeda872e6e8b815f9813cff682eb11060c3bb1b2ef12149f34d15c201a6b50fe438bf9776abda987 SHA512 7f54b7e87c1d3a5150e598052126e1c2f5396096450a68a923c9cfb7bcc48b724cddc61f55e34d1b5df103f5473367eb268877100f10c58d53fc3eaf24749d5b
+DIST v1.29.tar.gz 175970 BLAKE2B 8fa4192fc90b3a7ebe7ba9330191ad81e9c27dbec8e6cb657cf287cc66e4d3cc072ff032ea48311368401d7ba89b31015a9ca0c285a262336d6babfcb6457833 SHA512 adcf3706abd7fd2641388606dc2f39584607ec1f455bc52409c3905961cea446baecc5af80b6605ebb7167aef6f539b99f641cb39d97d396f32cea2aeb676561
diff --git a/net-misc/libteam/libteam-1.29.ebuild b/net-misc/libteam/libteam-1.29.ebuild
new file mode 100644
index 000000000000..44894e0e9a66
--- /dev/null
+++ b/net-misc/libteam/libteam-1.29.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools linux-info
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pirko/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/jpirko/libteam/archive/v${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Library and tools set for controlling team network device"
+HOMEPAGE="http://libteam.org"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="dbus debug examples static-libs +syslog zmq"
+
+DEPEND=">=dev-libs/jansson-2.4
+ dev-libs/libdaemon
+ >=dev-libs/libnl-3.2.19[utils]
+ dbus? ( sys-apps/dbus )
+ zmq? ( >=net-libs/zeromq-3.2.0 )
+ "
+
+RDEPEND="${DEPEND}
+ syslog? ( virtual/logger )"
+
+CONFIG_CHECK="~NET_TEAM ~NET_TEAM_MODE_ROUNDROBIN ~NET_TEAM_MODE_ACTIVEBACKUP ~NET_TEAM_MODE_BROADCAST ~NET_TEAM_MODE_RANDOM ~NET_TEAM_MODE_LOADBALANCE"
+ERROR_NET_TEAM="NET_TEAM is not enabled in this kernel!
+Only >=3.3.0 kernel version support in team mode"
+
+DOCS=( README )
+
+src_prepare(){
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable syslog logging) \
+ $(use_enable dbus) \
+ $(use_enable zmq)
+}
+
+src_install() {
+ default
+
+ insinto /etc/dbus-1/system.d
+ doins teamd/dbus/teamd.conf
+
+ if use examples; then
+ docinto examples
+ dodoc teamd/example_configs/*
+ fi
+}