summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-12-12 22:06:54 -0500
committerMike Gilbert <floppym@gentoo.org>2020-12-14 11:45:18 -0500
commita7e8b798856ce4d5b295005637b00b4921bd732c (patch)
treebf1b48de4d1a7432e8e464d8c6c2d238960748b4 /net-misc/modemmanager
parentmate-extra/mate-system-monitor: fix quoting for pkg-config (diff)
downloadgentoo-a7e8b798856ce4d5b295005637b00b4921bd732c.tar.gz
gentoo-a7e8b798856ce4d5b295005637b00b4921bd732c.tar.bz2
gentoo-a7e8b798856ce4d5b295005637b00b4921bd732c.zip
net-misc/modemmanager: fix quoting for pkg-config
Closes: https://bugs.gentoo.org/756238 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'net-misc/modemmanager')
-rw-r--r--net-misc/modemmanager/modemmanager-1.10.0.ebuild7
-rw-r--r--net-misc/modemmanager/modemmanager-1.8.2-r1.ebuild7
2 files changed, 8 insertions, 6 deletions
diff --git a/net-misc/modemmanager/modemmanager-1.10.0.ebuild b/net-misc/modemmanager/modemmanager-1.10.0.ebuild
index 0973aa512edd..7f108b8d46e9 100644
--- a/net-misc/modemmanager/modemmanager-1.10.0.ebuild
+++ b/net-misc/modemmanager/modemmanager-1.10.0.ebuild
@@ -5,7 +5,7 @@ EAPI=6
GNOME2_LA_PUNT="yes"
VALA_USE_DEPEND="vapigen"
-inherit gnome2 readme.gentoo-r1 systemd udev vala
+inherit gnome2 readme.gentoo-r1 systemd toolchain-funcs udev vala
DESCRIPTION="Modem and mobile broadband management libraries"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/ModemManager/"
@@ -75,10 +75,11 @@ src_configure() {
$(use_enable vala)
)
if use elogind; then
+ local pkgconfig="$(tc-getPKG_CONFIG)"
myconf+=(
--with-systemd-suspend-resume
- LIBSYSTEMD_LOGIN_CFLAGS=`pkg-config --cflags "libelogind" 2>/dev/null`
- LIBSYSTEMD_LOGIN_LIBS=`pkg-config --libs "libelogind" 2>/dev/null`
+ LIBSYSTEMD_LOGIN_CFLAGS="$(${pkgconfig} --cflags "libelogind")"
+ LIBSYSTEMD_LOGIN_LIBS="$(${pkgconfig} --libs "libelogind")"
)
fi
gnome2_src_configure "${myconf[@]}"
diff --git a/net-misc/modemmanager/modemmanager-1.8.2-r1.ebuild b/net-misc/modemmanager/modemmanager-1.8.2-r1.ebuild
index 1e50b9f22e50..347bb0a5d5f0 100644
--- a/net-misc/modemmanager/modemmanager-1.8.2-r1.ebuild
+++ b/net-misc/modemmanager/modemmanager-1.8.2-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=6
GNOME2_LA_PUNT="yes"
VALA_USE_DEPEND="vapigen"
-inherit gnome2 readme.gentoo-r1 systemd udev vala
+inherit gnome2 readme.gentoo-r1 systemd toolchain-funcs udev vala
DESCRIPTION="Modem and mobile broadband management libraries"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/ModemManager/"
@@ -75,10 +75,11 @@ src_configure() {
$(use_enable vala)
)
if use elogind; then
+ local pkgconfig="$(tc-getPKG_CONFIG)"
myconf+=(
--with-systemd-suspend-resume
- LIBSYSTEMD_LOGIN_CFLAGS=`pkg-config --cflags "libelogind" 2>/dev/null`
- LIBSYSTEMD_LOGIN_LIBS=`pkg-config --libs "libelogind" 2>/dev/null`
+ LIBSYSTEMD_LOGIN_CFLAGS="$(${pkgconfig} --cflags "libelogind")"
+ LIBSYSTEMD_LOGIN_LIBS="$(${pkgconfig} --libs "libelogind")"
)
fi
gnome2_src_configure "${myconf[@]}"