summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2021-10-27 19:38:40 +0200
committerAmy Liffey <amynka@gentoo.org>2021-10-27 20:59:46 +0200
commit392f6e131d6049bb2cd19a21eff2b407cb052a4c (patch)
treea5d08dddddf5a078c647fc45cee96009e9873374 /net-misc/mosh
parentnet-misc/mosh: eapi bump (diff)
downloadgentoo-392f6e131d6049bb2cd19a21eff2b407cb052a4c.tar.gz
gentoo-392f6e131d6049bb2cd19a21eff2b407cb052a4c.tar.bz2
gentoo-392f6e131d6049bb2cd19a21eff2b407cb052a4c.zip
net-misc/mosh: remove 9999 not needed anymore
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Amy Liffey <amynka@gentoo.org>
Diffstat (limited to 'net-misc/mosh')
-rw-r--r--net-misc/mosh/mosh-9999.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/net-misc/mosh/mosh-9999.ebuild b/net-misc/mosh/mosh-9999.ebuild
deleted file mode 100644
index 58c3c573a5fc..000000000000
--- a/net-misc/mosh/mosh-9999.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools bash-completion-r1 git-r3
-
-DESCRIPTION="Mobile shell that supports roaming and intelligent local echo"
-HOMEPAGE="https://mosh.org"
-EGIT_REPO_URI="https://github.com/keithw/mosh.git"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="+client examples +mosh-hardening +server ufw +utempter"
-
-REQUIRED_USE="
- || ( client server )
- examples? ( client )"
-
-RDEPEND="
- dev-libs/protobuf:0=
- sys-libs/ncurses:0=
- virtual/ssh
- client? (
- dev-lang/perl
- dev-perl/IO-Tty
- )
- dev-libs/openssl:0=
- utempter? (
- sys-libs/libutempter
- )"
-
-DEPEND="${RDEPEND}
- dev-vcs/git[curl]
- virtual/pkgconfig"
-
-# [0] - avoid sandbox-violation calling git describe in Makefile
-PATCHES=(
- "${FILESDIR}"/${PN}-1.2.5-git-version.patch
-)
-
-src_prepare() {
- MAKEOPTS+=" V=1"
- default
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-completion \
- $(use_enable client) \
- $(use_enable server) \
- $(use_enable examples) \
- $(use_enable ufw) \
- $(use_enable mosh-hardening hardening) \
- $(use_with utempter)
-}
-
-src_install() {
- default
-
- for myprog in $(find src/examples -type f -perm /0111) ; do
- newbin ${myprog} ${PN}-$(basename ${myprog})
- elog "${myprog} installed as ${PN}-$(basename ${myprog})"
- done
-
- # bug 477384
- dobashcomp conf/bash-completion/completions/mosh
-}