summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-12 12:36:30 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-12 12:36:30 +0200
commit89e80782350327dbcae6e70412b162f570274475 (patch)
tree572a52ab00c31fac0084ac9aec8871ac2a5532dc /net-misc/netctl
parentapp-leechcraft/lc-ooronee: Use optfeature from eutils.eclass (diff)
downloadgentoo-89e80782350327dbcae6e70412b162f570274475.tar.gz
gentoo-89e80782350327dbcae6e70412b162f570274475.tar.bz2
gentoo-89e80782350327dbcae6e70412b162f570274475.zip
net-misc/netctl: Use optfeature from eutils.eclass
Package-Manager: portage-2.2.20 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'net-misc/netctl')
-rw-r--r--net-misc/netctl/netctl-1.10.ebuild15
-rw-r--r--net-misc/netctl/netctl-1.9.ebuild15
-rw-r--r--net-misc/netctl/netctl-9999.ebuild17
3 files changed, 4 insertions, 43 deletions
diff --git a/net-misc/netctl/netctl-1.10.ebuild b/net-misc/netctl/netctl-1.10.ebuild
index 88a933e680b8..4a6ba6fb7d38 100644
--- a/net-misc/netctl/netctl-1.10.ebuild
+++ b/net-misc/netctl/netctl-1.10.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit bash-completion-r1
+inherit bash-completion-r1 eutils
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="git://projects.archlinux.org/netctl.git"
@@ -54,19 +54,6 @@ src_install() {
newins contrib/zsh-completion _netctl
}
-optfeature() {
- local desc=$1
- shift
- while (( $# )); do
- if has_version "$1"; then
- elog " [I] $1 for ${desc}"
- else
- elog " [ ] $1 for ${desc}"
- fi
- shift
- done
-}
-
pkg_postinst() {
if [[ -z ${REPLACING_VERSIONS} ]]; then
elog "To get additional features, a number of optional runtime dependencies may be"
diff --git a/net-misc/netctl/netctl-1.9.ebuild b/net-misc/netctl/netctl-1.9.ebuild
index 8fd90dca1862..cf44dd20c24c 100644
--- a/net-misc/netctl/netctl-1.9.ebuild
+++ b/net-misc/netctl/netctl-1.9.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit bash-completion-r1
+inherit bash-completion-r1 eutils
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="git://projects.archlinux.org/netctl.git"
@@ -54,19 +54,6 @@ src_install() {
newins contrib/zsh-completion _netctl
}
-optfeature() {
- local desc=$1
- shift
- while (( $# )); do
- if has_version "$1"; then
- elog " [I] $1 for ${desc}"
- else
- elog " [ ] $1 for ${desc}"
- fi
- shift
- done
-}
-
pkg_postinst() {
if [[ -z ${REPLACING_VERSIONS} ]]; then
elog "To get additional features, a number of optional runtime dependencies may be"
diff --git a/net-misc/netctl/netctl-9999.ebuild b/net-misc/netctl/netctl-9999.ebuild
index 87bbb92b396b..d85787dd2937 100644
--- a/net-misc/netctl/netctl-9999.ebuild
+++ b/net-misc/netctl/netctl-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit bash-completion-r1
+inherit bash-completion-r1 eutils
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="git://projects.archlinux.org/netctl.git"
@@ -53,19 +53,6 @@ src_install() {
newins contrib/zsh-completion _netctl
}
-optfeature() {
- local desc=$1
- shift
- while (( $# )); do
- if has_version "$1"; then
- elog " [I] $1 for ${desc}"
- else
- elog " [ ] $1 for ${desc}"
- fi
- shift
- done
-}
-
pkg_postinst() {
if [[ -z ${REPLACING_VERSIONS} ]]; then
elog "To get additional features, a number of optional runtime dependencies may be"