summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/netkit-fingerd/netkit-fingerd-0.17-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/netkit-fingerd/netkit-fingerd-0.17-r3.ebuild')
-rw-r--r--net-misc/netkit-fingerd/netkit-fingerd-0.17-r3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/netkit-fingerd/netkit-fingerd-0.17-r3.ebuild b/net-misc/netkit-fingerd/netkit-fingerd-0.17-r3.ebuild
new file mode 100644
index 000000000000..12735af1caf9
--- /dev/null
+++ b/net-misc/netkit-fingerd/netkit-fingerd-0.17-r3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+MY_PN="${PN/netkit/bsd}"
+MY_PN="${MY_PN/rd/r}"
+DESCRIPTION="Netkit - fingerd and finger client"
+HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
+SRC_URI="mirror://debian/pool/main/b/${MY_PN}/${MY_PN}_${PV}.orig.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-r2-gentoo.diff
+ epatch "${FILESDIR}"/${P}-name-check.patch #80286
+}
+
+src_configure() {
+ # We'll skip this stage as the configure script is crappy and not really
+ # needed -- src_install installs all files by hand.
+ touch MCONFIG
+ tc-export CC
+}
+
+src_compile() {
+ emake CC="${CC}"
+}
+
+src_install() {
+ dobin finger/finger
+ dosbin fingerd/fingerd
+ dosym fingerd /usr/sbin/in.fingerd
+ doman finger/finger.1 fingerd/fingerd.8
+ dosym fingerd.8 /usr/share/man/man8/in.fingerd.8
+ dodoc README ChangeLog BUGS
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/fingerd.xinetd fingerd
+}