summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-01-03 22:29:42 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-01-04 15:59:59 +0000
commitfd91a465ca26bbee9ee2469ca6f97ee9846a53c1 (patch)
tree90a8cb55c247cf9b68c92782f0614409500e02e7 /net-misc/ntpclient/ntpclient-2015.365.ebuild
parentapp-misc/carbon-c-relay: version bump to 1.4 (diff)
downloadgentoo-fd91a465ca26bbee9ee2469ca6f97ee9846a53c1.tar.gz
gentoo-fd91a465ca26bbee9ee2469ca6f97ee9846a53c1.tar.bz2
gentoo-fd91a465ca26bbee9ee2469ca6f97ee9846a53c1.zip
net-misc/ntpclient: Version bump. EAPI 6 bump. Take over maintainership.
Package-Manager: portage-2.2.26 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-misc/ntpclient/ntpclient-2015.365.ebuild')
-rw-r--r--net-misc/ntpclient/ntpclient-2015.365.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/ntpclient/ntpclient-2015.365.ebuild b/net-misc/ntpclient/ntpclient-2015.365.ebuild
new file mode 100644
index 000000000000..b2124eb105d0
--- /dev/null
+++ b/net-misc/ntpclient/ntpclient-2015.365.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A NTP (RFC-1305) client for unix-alike computers"
+HOMEPAGE="http://doolittle.icarus.com/ntpclient/"
+SRC_URI="http://doolittle.icarus.com/${PN}/${PN}_${PV/./_}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+src_unpack() {
+ default
+ mv "${WORKDIR}"/${PN}* ${P} || die
+}
+
+src_prepare() {
+ default
+ sed -i -e 's/-O2//;s/LDFLAGS +=/LDLIBS +=/' Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ dobin "${PN}"
+ dodoc README HOWTO rate.awk rate2.awk
+}