summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Arnold <nerdboy@gentoo.org>2019-08-04 21:58:15 -0700
committerStephen Arnold <nerdboy@gentoo.org>2019-08-04 21:59:18 -0700
commita9623dcbb24918843d9454ae04b6b277d25fa2ab (patch)
tree599b5917b950340936dc44feed94fc8ced7f2e58 /net-misc/ntpsec/ntpsec-1.1.6.ebuild
parentapp-crypt/yubikey-manager-qt: remove old (diff)
downloadgentoo-a9623dcbb24918843d9454ae04b6b277d25fa2ab.tar.gz
gentoo-a9623dcbb24918843d9454ae04b6b277d25fa2ab.tar.bz2
gentoo-a9623dcbb24918843d9454ae04b6b277d25fa2ab.zip
net-misc/ntpsec: update ebuilds and use flags, fix for bug #685456
* (modified) patch supplied by James Browning <jamesb.fe80@gmail.com> only applies to 1.1.4 and up * remove obsolete configure option from 1.1.6 and up Package-Manager: Portage-2.3.67, Repoman-2.3.12 Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
Diffstat (limited to 'net-misc/ntpsec/ntpsec-1.1.6.ebuild')
-rw-r--r--net-misc/ntpsec/ntpsec-1.1.6.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-misc/ntpsec/ntpsec-1.1.6.ebuild b/net-misc/ntpsec/ntpsec-1.1.6.ebuild
index d8f848a621db..cbf16e45b9f8 100644
--- a/net-misc/ntpsec/ntpsec-1.1.6.ebuild
+++ b/net-misc/ntpsec/ntpsec-1.1.6.ebuild
@@ -32,15 +32,17 @@ IUSE_NTPSEC_REFCLOCK=${NTPSEC_REFCLOCK[@]/#/rclock_}
LICENSE="HPND MIT BSD-2 BSD CC-BY-SA-4.0"
SLOT="0"
-IUSE="${IUSE_NTPSEC_REFCLOCK} debug doc early gdb heat nist ntpviz samba seccomp smear tests" #ionice
+IUSE="${IUSE_NTPSEC_REFCLOCK} debug doc early gdb heat libbsd libressl nist ntpviz samba seccomp smear tests" #ionice
REQUIRED_USE="${PYTHON_REQUIRED_USE} nist? ( rclock_local )"
# net-misc/pps-tools oncore,pps
CDEPEND="${PYTHON_DEPS}
${BDEPEND}
sys-libs/libcap
- dev-libs/openssl:0=
dev-python/psutil[${PYTHON_USEDEP}]
+ libbsd? ( dev-libs/libbsd:0= )
+ libressl? ( dev-libs/libressl:0= )
+ !libressl? ( dev-libs/openssl:0= )
seccomp? ( sys-libs/libseccomp )
"
RDEPEND="${CDEPEND}
@@ -50,6 +52,7 @@ RDEPEND="${CDEPEND}
"
DEPEND="${CDEPEND}
app-text/asciidoc
+ dev-libs/libxslt
app-text/docbook-xsl-stylesheets
sys-devel/bison
rclock_oncore? ( net-misc/pps-tools )
@@ -67,6 +70,9 @@ src_prepare() {
default
# Remove autostripping of binaries
sed -i -e '/Strip binaries/d' wscript
+ if ! use libbsd ; then
+ epatch "${FILESDIR}/${PN}-no-bsd.patch"
+ fi
python_copy_sources
}
@@ -91,7 +97,6 @@ src_configure() {
$(use doc && echo "--enable-doc")
$(use early && echo "--enable-early-droproot")
$(use gdb && echo "--enable-debug-gdb")
- $(use nist && echo "--enable-lockclock")
$(use samba && echo "--enable-mssntp")
$(use seccomp && echo "--enable-seccomp")
$(use smear && echo "--enable-leap-smear")