summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Arnold <nerdboy@gentoo.org>2020-03-09 16:54:18 -0700
committerStephen Arnold <nerdboy@gentoo.org>2020-03-09 17:01:50 -0700
commit47924c9cc6c4597423b6147b2c246ab6438fa027 (patch)
tree5c57613912711a9520379c4113773536ad22eeb3 /net-misc/ntpsec
parenttoolchain.eclass: move --build dependencies to BDEPEND (diff)
downloadgentoo-47924c9cc6c4597423b6147b2c246ab6438fa027.tar.gz
gentoo-47924c9cc6c4597423b6147b2c246ab6438fa027.tar.bz2
gentoo-47924c9cc6c4597423b6147b2c246ab6438fa027.zip
net-misc/ntpsec: add upstream patch and expand py3 compat
* closes bugs #709258 and #710414 Package-Manager: Portage-2.3.67, Repoman-2.3.17 Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
Diffstat (limited to 'net-misc/ntpsec')
-rw-r--r--net-misc/ntpsec/files/ntpsec-1.1.8-externalize-sys_maxclock-fix-for-bug-708522.patch23
-rw-r--r--net-misc/ntpsec/ntpsec-1.1.8.ebuild4
-rw-r--r--net-misc/ntpsec/ntpsec-9999.ebuild2
3 files changed, 27 insertions, 2 deletions
diff --git a/net-misc/ntpsec/files/ntpsec-1.1.8-externalize-sys_maxclock-fix-for-bug-708522.patch b/net-misc/ntpsec/files/ntpsec-1.1.8-externalize-sys_maxclock-fix-for-bug-708522.patch
new file mode 100644
index 000000000000..caeaf1824cc5
--- /dev/null
+++ b/net-misc/ntpsec/files/ntpsec-1.1.8-externalize-sys_maxclock-fix-for-bug-708522.patch
@@ -0,0 +1,23 @@
+From ccdd9d4b941b30fc44b301595e42809dbe48628d Mon Sep 17 00:00:00 2001
+From: James Browning <JamesB.fe80@gmail.com>
+Date: Sun, 26 Jan 2020 09:58:36 -0800
+Subject: [PATCH] Externalize sys_maxclock from include/ntpd.h ...
+
+I think this will shut up the Fedora Rawhide runners
+---
+ include/ntpd.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/ntpd.h b/include/ntpd.h
+index c4f9b9e45..ee16678e1 100644
+--- a/include/ntpd.h
++++ b/include/ntpd.h
+@@ -369,7 +369,7 @@ extern int peer_associations; /* mobilized associations */
+ * System variables are declared here. See Section 3.2 of the
+ * specification.
+ */
+-int sys_maxclock; /* maximum candidates */
++extern int sys_maxclock; /* maximum candidates */
+ struct system_variables {
+ uint8_t sys_leap; /* system leap indicator */
+ uint8_t sys_stratum; /* system stratum */
diff --git a/net-misc/ntpsec/ntpsec-1.1.8.ebuild b/net-misc/ntpsec/ntpsec-1.1.8.ebuild
index 1316806dc69d..128e2a23826c 100644
--- a/net-misc/ntpsec/ntpsec-1.1.8.ebuild
+++ b/net-misc/ntpsec/ntpsec-1.1.8.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE='threads(+)'
inherit flag-o-matic python-r1 waf-utils systemd
@@ -62,6 +62,8 @@ DEPEND="${CDEPEND}
WAF_BINARY="${S}/waf"
+PATCHES=( "${FILESDIR}/${P}-externalize-sys_maxclock-fix-for-bug-708522.patch" )
+
src_prepare() {
default
# Remove autostripping of binaries
diff --git a/net-misc/ntpsec/ntpsec-9999.ebuild b/net-misc/ntpsec/ntpsec-9999.ebuild
index 1316806dc69d..36dc8d080881 100644
--- a/net-misc/ntpsec/ntpsec-9999.ebuild
+++ b/net-misc/ntpsec/ntpsec-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE='threads(+)'
inherit flag-o-matic python-r1 waf-utils systemd