summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/ofono/ofono-1.14.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/ofono/ofono-1.14.ebuild')
-rw-r--r--net-misc/ofono/ofono-1.14.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/net-misc/ofono/ofono-1.14.ebuild b/net-misc/ofono/ofono-1.14.ebuild
new file mode 100644
index 000000000000..4b7451d5a404
--- /dev/null
+++ b/net-misc/ofono/ofono-1.14.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib systemd
+
+DESCRIPTION="Open Source mobile telephony (GSM/UMTS) daemon"
+HOMEPAGE="http://ofono.org/"
+SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE="+atmodem bluetooth +cdmamodem +datafiles doc dundee examples +isimodem +phonesim +provision +qmimodem threads tools +udev"
+
+REQUIRED_USE="dundee? ( bluetooth )"
+
+RDEPEND=">=sys-apps/dbus-1.4
+ >=dev-libs/glib-2.28
+ net-misc/mobile-broadband-provider-info
+ bluetooth? ( >=net-wireless/bluez-4.99 )
+ udev? ( virtual/udev )
+ examples? ( dev-python/dbus-python )
+ tools? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( ChangeLog AUTHORS )
+
+src_configure() {
+ econf \
+ $(use_enable threads) \
+ $(use_enable udev) \
+ $(use_enable isimodem) \
+ $(use_enable atmodem) \
+ $(use_enable cdmamodem) \
+ $(use_enable datafiles) \
+ $(use_enable dundee) \
+ $(use_enable bluetooth) \
+ $(use_enable phonesim) \
+ $(use_enable provision) \
+ $(use_enable qmimodem) \
+ $(use_enable tools) \
+ $(use_enable examples test) \
+ --disable-maintainer-mode \
+ --localstatedir=/var \
+ --with-systemdunitdir="$(systemd_get_unitdir)"
+}
+
+src_install() {
+ default
+
+ if use tools ; then
+ dobin tools/auto-enable \
+ tools/huawei-audio \
+ tools/lookup-provider-name \
+ tools/lookup-apn \
+ tools/get-location \
+ tools/qmi \
+ tools/tty-redirector
+ fi
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ use doc && dodoc doc/*.txt
+}