summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2017-05-26 15:15:05 +0800
committerYixun Lan <dlan@gentoo.org>2017-06-05 17:54:31 +0800
commit5949bfbac8aedafc8d2d72797474b264e8bf71f4 (patch)
tree9130fa2a2c82906d233b40ba22ad4629f965cf9a /net-misc/ofono/ofono-1.20.ebuild
parentdev-perl/Test-Timer: Bump to version 1.0.0 (diff)
downloadgentoo-5949bfbac8aedafc8d2d72797474b264e8bf71f4.tar.gz
gentoo-5949bfbac8aedafc8d2d72797474b264e8bf71f4.tar.bz2
gentoo-5949bfbac8aedafc8d2d72797474b264e8bf71f4.zip
net-misc/ofono: version bump 1.20
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-misc/ofono/ofono-1.20.ebuild')
-rw-r--r--net-misc/ofono/ofono-1.20.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/net-misc/ofono/ofono-1.20.ebuild b/net-misc/ofono/ofono-1.20.ebuild
new file mode 100644
index 000000000000..af59f3820ac1
--- /dev/null
+++ b/net-misc/ofono/ofono-1.20.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils multilib systemd
+
+DESCRIPTION="Open Source mobile telephony (GSM/UMTS) daemon"
+HOMEPAGE="http://ofono.org/"
+SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+atmodem bluetooth +cdmamodem +datafiles doc dundee examples +isimodem +phonesim +provision +qmimodem threads tools +udev upower"
+
+REQUIRED_USE="dundee? ( bluetooth )"
+
+RDEPEND=">=sys-apps/dbus-1.4
+ >=dev-libs/glib-2.32
+ net-misc/mobile-broadband-provider-info
+ bluetooth? ( >=net-wireless/bluez-4.99 )
+ udev? ( virtual/udev )
+ examples? ( dev-python/dbus-python )
+ tools? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( ChangeLog AUTHORS )
+
+src_configure() {
+ econf \
+ $(use_enable threads) \
+ $(use_enable udev) \
+ $(use_enable isimodem) \
+ $(use_enable atmodem) \
+ $(use_enable cdmamodem) \
+ $(use_enable datafiles) \
+ $(use_enable dundee) \
+ $(use_enable bluetooth) \
+ $(use_enable phonesim) \
+ $(use_enable provision) \
+ $(use_enable qmimodem) \
+ $(use_enable tools) \
+ $(use_enable examples test) \
+ $(use_enable upower) \
+ --disable-maintainer-mode \
+ --disable-rilmodem
+ --localstatedir=/var \
+ --with-systemdunitdir="$(systemd_get_systemunitdir)"
+}
+
+src_install() {
+ default
+
+ if use tools ; then
+ dobin tools/auto-enable \
+ tools/huawei-audio \
+ tools/lookup-provider-name \
+ tools/lookup-apn \
+ tools/get-location \
+ tools/tty-redirector
+ fi
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ use doc && dodoc doc/*.txt
+}