summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-10-03 21:29:50 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-10-03 21:30:09 -0500
commit41773ba59880d160d83ce6e67abda2dbd8bc90fd (patch)
tree0862b844f619913ddce188c31ae1f1c24780ad72 /net-misc/openvswitch
parentdev-python/ovs: bump for openvswitch-2.8.1 (diff)
downloadgentoo-41773ba59880d160d83ce6e67abda2dbd8bc90fd.tar.gz
gentoo-41773ba59880d160d83ce6e67abda2dbd8bc90fd.tar.bz2
gentoo-41773ba59880d160d83ce6e67abda2dbd8bc90fd.zip
net-misc/openvswitch: 2.8.1 bup for CVE-2017-14970 bug 633420
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-misc/openvswitch')
-rw-r--r--net-misc/openvswitch/Manifest1
-rw-r--r--net-misc/openvswitch/openvswitch-2.8.1.ebuild155
2 files changed, 156 insertions, 0 deletions
diff --git a/net-misc/openvswitch/Manifest b/net-misc/openvswitch/Manifest
index f3657364ffad..bb25830ae85d 100644
--- a/net-misc/openvswitch/Manifest
+++ b/net-misc/openvswitch/Manifest
@@ -1,2 +1,3 @@
DIST openvswitch-2.6.1.tar.gz 5399107 SHA256 307b20aba6a179bf13e5da9ac242933c31349073762473a9d4782619c8c1cf0c SHA512 c5a716d2d9ac5f353827a4ad1e26f4d0ddfc4d7bf1e8f696043c32676e77c068e3e0dd423348cc33d5507753d7a27ce24898b823dad3fbc6a8d79297fa088b39 WHIRLPOOL 1ab35852ad45fc99964c814923ea54b22ec6c4630b2aa6cb6aee7b96ca806095d0be60c1b08f926419efa79a3c7ce4d484efe497bb50a9596db69b6020175092
DIST openvswitch-2.7.2.tar.gz 6192414 SHA256 fe36c86ed52f6f7c17b01cdbb7ae37bf521cc5c2e50997b618f3f742485f655b SHA512 790a715dd31729893a1c21af4197400b7362569d15cb763cbbab82830c5f5168d2dea0cb40282faa17734a2ad967bc40d02b8f4f92ea585164386d2aa0719470 WHIRLPOOL 6525d475cc10b3e32d5b9c01cbfd909dff3cfad28bbe13bf55b5775471a58fd49e9f9cf484a9e68a0f371c56824910142513c34dc5d2f11a0dcebf5b789e75d4
+DIST openvswitch-2.8.1.tar.gz 6746474 SHA256 8d1c439e26d7044f0ec823c7fef1b00b7c6465da0b83a7d0cf3191ed1dc43893 SHA512 b9e90b49bb91aef80942b146e7e324b74f8961342dcc7836f2551ea976a69d66506a3a739bcb01a926b3b3874c7e4312de02965738a1536a342ab95f935d92f7 WHIRLPOOL 864ac85d1330cf04cf499dcbbbed0e0b09351795a5ecd780e0f94cae3dc744229875181cea05fa39a7108583271319cedc7a0dfc77b7793453c76604e81a7fe1
diff --git a/net-misc/openvswitch/openvswitch-2.8.1.ebuild b/net-misc/openvswitch/openvswitch-2.8.1.ebuild
new file mode 100644
index 000000000000..35188c9569d4
--- /dev/null
+++ b/net-misc/openvswitch/openvswitch-2.8.1.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit autotools eutils linux-info linux-mod python-r1 systemd
+
+DESCRIPTION="Production quality, multilayer virtual switch"
+HOMEPAGE="http://openvswitch.org"
+SRC_URI="http://openvswitch.org/releases/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="debug modules monitor +ssl"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ || (
+ >=sys-apps/openrc-0.10.5
+ sys-apps/systemd
+ )
+ ssl? ( dev-libs/openssl:0= )
+ ${PYTHON_DEPS}
+ ~dev-python/ovs-2.7.2[${PYTHON_USEDEP}]
+ || (
+ dev-python/twisted[conch,${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]
+ )
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ debug? ( dev-lang/perl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES="${FILESDIR}/xcp-interface-reconfigure-2.3.2.patch"
+
+CONFIG_CHECK="~NET_CLS_ACT ~NET_CLS_U32 ~NET_SCH_INGRESS ~NET_ACT_POLICE ~IPV6 ~TUN"
+MODULE_NAMES="openvswitch(net:${S}/datapath/linux)"
+BUILD_TARGETS="all"
+
+pkg_setup() {
+ if use modules ; then
+ CONFIG_CHECK+=" ~!OPENVSWITCH"
+ kernel_is ge 3 10 0 || die "Linux >= 3.10.0 and <= 4.8 required for userspace modules"
+ kernel_is le 4 9 999 || die "Linux >= 3.10.0 and <= 4.8 required for userspace modules"
+ linux-mod_pkg_setup
+ else
+ CONFIG_CHECK+=" ~OPENVSWITCH"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # Never build kernelmodules, doing this manually
+ sed -i \
+ -e '/^SUBDIRS/d' \
+ datapath/Makefile.in || die "sed failed"
+ eautoreconf
+ default
+}
+
+src_configure() {
+ set_arch_to_kernel
+ # monitor is statically enabled for bug 596206
+ # use monitor || export ovs_cv_python="no"
+ # pyside is staticly disabled
+ export ovs_cv_pyuic4="no"
+
+ local linux_config
+ use modules && linux_config="--with-linux=${KV_OUT_DIR}"
+
+ econf ${linux_config} \
+ --with-rundir=/var/run/openvswitch \
+ --with-logdir=/var/log/openvswitch \
+ --with-pkidir=/etc/ssl/openvswitch \
+ --with-dbdir=/var/lib/openvswitch \
+ $(use_enable ssl) \
+ $(use_enable !debug ndebug)
+}
+
+src_compile() {
+ default
+
+ use modules && linux-mod_src_compile
+}
+
+src_install() {
+ default
+
+ local SCRIPT
+ if use monitor; then
+ for SCRIPT in ovs-{pcap,parse-backtrace,dpctl-top,l3ping,tcpdump,tcpundump,test,vlan-test} bugtool/ovs-bugtool; do
+ sed -e '1s|^.*$|#!/usr/bin/python|' -i utilities/"${SCRIPT}"
+ python_foreach_impl python_doscript utilities/"${SCRIPT}"
+ done
+ rm -r "${ED%/}"/usr/share/openvswitch/python || die
+ fi
+
+ keepdir /var/{lib,log}/openvswitch
+ keepdir /etc/ssl/openvswitch
+ fperms 0750 /etc/ssl/openvswitch
+
+ rm -rf "${ED%/}"/var/run || die
+
+ newconfd "${FILESDIR}/ovsdb-server_conf2" ovsdb-server
+ newconfd "${FILESDIR}/ovs-vswitchd_conf" ovs-vswitchd
+ newinitd "${FILESDIR}/ovsdb-server-r1" ovsdb-server
+ newinitd "${FILESDIR}/ovs-vswitchd-r1" ovs-vswitchd
+
+ systemd_dounit "${FILESDIR}/ovsdb-server.service"
+ systemd_dounit "${FILESDIR}/ovs-vswitchd.service"
+ systemd_newtmpfilesd "${FILESDIR}/openvswitch.tmpfiles" openvswitch.conf
+
+ insinto /etc/logrotate.d
+ newins rhel/etc_logrotate.d_openvswitch openvswitch
+
+ use modules && linux-mod_src_install
+}
+
+pkg_postinst() {
+ use modules && linux-mod_pkg_postinst
+
+ local pv
+ for pv in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 1.9.0 ${pv} ; then
+ ewarn "The configuration database for Open vSwitch got moved in version 1.9.0 from"
+ ewarn " /etc/openvswitch"
+ ewarn "to"
+ ewarn " /var/lib/openvswitch"
+ ewarn "Please copy/move the database manually before running the schema upgrade."
+ ewarn "The PKI files are now supposed to go to /etc/ssl/openvswitch"
+ fi
+ done
+
+ elog "Use the following command to create an initial database for ovsdb-server:"
+ elog " emerge --config =${CATEGORY}/${PF}"
+ elog "(will create a database in /var/lib/openvswitch/conf.db)"
+ elog "or to convert the database to the current schema after upgrading."
+}
+
+pkg_config() {
+ local db="${EROOT%/}"/var/lib/openvswitch/conf.db
+ if [[ -e "${db}" ]] ; then
+ einfo "Database '${db}' already exists, doing schema migration..."
+ einfo "(if the migration fails, make sure that ovsdb-server is not running)"
+ ovsdb-tool convert "${db}" \
+ "${EROOT%/}"/usr/share/openvswitch/vswitch.ovsschema || die "converting database failed"
+ else
+ einfo "Creating new database '${db}'..."
+ ovsdb-tool create "${db}" \
+ "${EROOT%/}"/usr/share/openvswitch/vswitch.ovsschema || die "creating database failed"
+ fi
+}