summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2018-01-20 19:05:13 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-30 11:28:43 +0100
commitf3042e074b7763c09bf274d366bbe31f0e55e417 (patch)
tree6d9418d88a49f6f4a7c8b84a0d1a8a8dd349002e /net-misc/pingu/pingu-9999.ebuild
parentnet-analyzer/ossec-hids: open source HIDS (new package) (diff)
downloadgentoo-f3042e074b7763c09bf274d366bbe31f0e55e417.tar.gz
gentoo-f3042e074b7763c09bf274d366bbe31f0e55e417.tar.bz2
gentoo-f3042e074b7763c09bf274d366bbe31f0e55e417.zip
net-misc/pingu: new ebuild
Pingu is a daemon that takes care of policy routing and fail-over in multi ISP setups. Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua> Package-Manager: Portage-2.3.49, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10194 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-misc/pingu/pingu-9999.ebuild')
-rw-r--r--net-misc/pingu/pingu-9999.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-misc/pingu/pingu-9999.ebuild b/net-misc/pingu/pingu-9999.ebuild
new file mode 100644
index 000000000000..30ea3b2eab70
--- /dev/null
+++ b/net-misc/pingu/pingu-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit git-r3 systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="Policy routing daemon with failover and load-balancing"
+HOMEPAGE="https://github.com/ncopa/pingu"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/ncopa/${PN}.git"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug doc"
+
+RDEPEND="dev-libs/libev:="
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+ virtual/pkgconfig
+ doc? ( app-text/asciidoc )"
+
+# Fix QA with install into path /run/pingu must be created at runtime
+PATCHES=( "${FILESDIR}"/"${PN}"-1.5-makefile.patch )
+
+src_configure() {
+ ./configure "$(use_enable debug)" "$(use_enable doc)" \
+ --prefix=/usr || die "configure failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ default
+
+ newtmpfiles "${FILESDIR}"/pingu.tmpfile pingu.conf
+ newinitd "${FILESDIR}"/pingu.initd pingu
+ newconfd "${FILESDIR}"/pingu.confd pingu
+ systemd_dounit "${FILESDIR}"/pingu.service
+ keepdir /var/lib/pingu
+ insinto /etc/pingu
+ newins pingu.conf pingu.conf.example
+}
+
+pkg_postinst() {
+ tmpfiles_process pingu.conf
+}