summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/polly
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/polly')
-rw-r--r--net-misc/polly/Manifest2
-rw-r--r--net-misc/polly/metadata.xml12
-rw-r--r--net-misc/polly/polly-0.93.11.ebuild51
-rw-r--r--net-misc/polly/polly-0.93.12.ebuild53
4 files changed, 118 insertions, 0 deletions
diff --git a/net-misc/polly/Manifest b/net-misc/polly/Manifest
new file mode 100644
index 000000000000..02767fd8187b
--- /dev/null
+++ b/net-misc/polly/Manifest
@@ -0,0 +1,2 @@
+DIST Polly-0.93.12.tar.gz 573637 SHA256 376ae60067b192bc5d5147203f9116e207599f73929dfb8b6343be9f250ba410 SHA512 71cef70d6ed8ade018a880a81c9ec83f9d32f2dde3c5fb192655f56d39e6cc17ac164e746085434caca863af08a075a3a7f05b9010a263956b92294fa4b4f370 WHIRLPOOL ffc852531b8350f28c0c0e191373db5525aab42bf1d974d2a9f94f395af1118b5d0d80cec5e3285630c38c9da470cd5e0115e6210a06e1245ec61ece8902b8f1
+DIST polly-0.93.11.tar.gz 575357 SHA256 c1e4c2d2c419626da484870e53866afdfbf14156bc2929f510c7f1142b457416 SHA512 75ded540371f63202cf84f685f5fbd9a6be0766bb03089ae2afc6b8056dbd28213ed1dda235fe53b285677e0fe9fdf3b3fd7b744d61824de607eb89c55cc299f WHIRLPOOL c9ec57320b5f552235409bd041f9c0242da9067c3b55fd8e3623ffa32170e4f7e8dd72f02b94df6830fdd28afb2b7912e185a79c9f08f74dad0be253960874fa
diff --git a/net-misc/polly/metadata.xml b/net-misc/polly/metadata.xml
new file mode 100644
index 000000000000..14d2eabbeacb
--- /dev/null
+++ b/net-misc/polly/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">polly</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/polly/polly-0.93.11.ebuild b/net-misc/polly/polly-0.93.11.ebuild
new file mode 100644
index 000000000000..70a222f09344
--- /dev/null
+++ b/net-misc/polly/polly-0.93.11.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTON_REQ_USE=( gdbm )
+DISTUTILS_NO_PARALLEL_BUILD=1
+
+inherit distutils-r1 gnome2-utils vcs-snapshot
+
+DESCRIPTION="twitter client designed for multiple columns of multiple accounts"
+HOMEPAGE="https://launchpad.net/polly"
+SRC_URI="https://launchpad.net/${PN}/1.0/pre-alpha-2/+download/Polly-${PV}%20%28pre-alpha%203.11%29.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC-BY-NC-SA-3.0 GPL-2 GPL-3+ MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/gconf-python[${PYTHON_USEDEP}]
+ dev-python/gtkspell-python[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/notify-python[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/oauth2[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/socksipy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_prepare_all() {
+ rm -rf external/keyring || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_preinst() {
+ gnome2_gconf_savelist
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+}
+
+pkg_postrm() {
+ gnome2_gconf_uninstall
+}
diff --git a/net-misc/polly/polly-0.93.12.ebuild b/net-misc/polly/polly-0.93.12.ebuild
new file mode 100644
index 000000000000..cc0b29b9b4d0
--- /dev/null
+++ b/net-misc/polly/polly-0.93.12.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTON_REQ_USE=( gdbm )
+DISTUTILS_NO_PARALLEL_BUILD=1
+
+inherit distutils-r1 gnome2-utils vcs-snapshot
+
+DESCRIPTION="twitter client designed for multiple columns of multiple accounts"
+HOMEPAGE="https://launchpad.net/polly"
+SRC_URI="https://launchpad.net/${PN}/1.0/pre-alpha-2/+download/Polly-${PV}.tar.gz"
+
+LICENSE="CC-BY-NC-SA-3.0 GPL-2 GPL-3+ MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/gconf-python[${PYTHON_USEDEP}]
+ dev-python/gtkspell-python[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/notify-python[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/oauth2[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/socksipy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/Polly-${PV}
+
+python_prepare_all() {
+ rm -rf external/keyring || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_preinst() {
+ gnome2_gconf_savelist
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+}
+
+pkg_postrm() {
+ gnome2_gconf_uninstall
+}