summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-21 15:45:54 +0100
committerSam James <sam@gentoo.org>2021-02-22 22:18:44 +0000
commit96e33b39e1520fb9b47d18be6ae65f27c6b414c4 (patch)
treeda4e125e84a242d8e51bcb6f1b9e7a53f9f97422 /net-misc/python-x2go
parentsci-electronics/drahnr-oregano: Port to python 3.{8,9} (diff)
downloadgentoo-96e33b39e1520fb9b47d18be6ae65f27c6b414c4.tar.gz
gentoo-96e33b39e1520fb9b47d18be6ae65f27c6b414c4.tar.bz2
gentoo-96e33b39e1520fb9b47d18be6ae65f27c6b414c4.zip
net-misc/python-x2go: Port to python 3.{8,9}
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/python-x2go')
-rw-r--r--net-misc/python-x2go/python-x2go-0.6.1.3.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/net-misc/python-x2go/python-x2go-0.6.1.3.ebuild b/net-misc/python-x2go/python-x2go-0.6.1.3.ebuild
index 27dda838f0d4..0b9387f66df8 100644
--- a/net-misc/python-x2go/python-x2go-0.6.1.3.ebuild
+++ b/net-misc/python-x2go/python-x2go-0.6.1.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_7 )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="X2Go client-side Python API"
@@ -13,11 +13,10 @@ SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
LICENSE="AGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
# TODO: minimal USE flag in net-misc/nx, we only need nxproxy/nxcomp
-DEPEND="dev-python/gevent[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-python/gevent[${PYTHON_USEDEP}]
dev-python/paramiko[${PYTHON_USEDEP}]
dev-python/python-xlib[${PYTHON_USEDEP}]
net-misc/nx"
-RDEPEND="${DEPEND}"