summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-05-03 19:34:29 -0500
committerAustin English <wizardedit@gentoo.org>2016-05-03 19:34:29 -0500
commitee1a0f757602c408482acbedfdc76507bb4d1f85 (patch)
tree2e1faf90db3be8aadeb8ddca009ec4c693ef6932 /net-misc/rinetd
parentnet-misc/portfwd: remove old version (diff)
downloadgentoo-ee1a0f757602c408482acbedfdc76507bb4d1f85.tar.gz
gentoo-ee1a0f757602c408482acbedfdc76507bb4d1f85.tar.bz2
gentoo-ee1a0f757602c408482acbedfdc76507bb4d1f85.zip
net-misc/rinetd: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc/rinetd')
-rw-r--r--net-misc/rinetd/files/rinetd.rc4
-rw-r--r--net-misc/rinetd/rinetd-0.62-r2.ebuild34
2 files changed, 36 insertions, 2 deletions
diff --git a/net-misc/rinetd/files/rinetd.rc b/net-misc/rinetd/files/rinetd.rc
index 9fe4d41e92cf..88807c95c7bc 100644
--- a/net-misc/rinetd/files/rinetd.rc
+++ b/net-misc/rinetd/files/rinetd.rc
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/net-misc/rinetd/rinetd-0.62-r2.ebuild b/net-misc/rinetd/rinetd-0.62-r2.ebuild
new file mode 100644
index 000000000000..862eb5cc3739
--- /dev/null
+++ b/net-misc/rinetd/rinetd-0.62-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="redirects TCP connections from one IP address and port to another"
+HOMEPAGE="http://www.boutell.com/rinetd/"
+SRC_URI="http://www.boutell.com/rinetd/http/rinetd.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ default
+ sed -i -e "s:gcc:$(tc-getCC) \$(CFLAGS) \$(LDFLAGS):" Makefile
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -DLINUX" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dosbin rinetd
+ newinitd "${FILESDIR}"/rinetd.rc rinetd
+ doman rinetd.8
+ dodoc CHANGES README index.html
+}