summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-05-03 19:36:22 -0500
committerAustin English <wizardedit@gentoo.org>2016-05-03 19:36:22 -0500
commit97f09c02250fe75429e186aeabb2ddafc2e1fa25 (patch)
treece90b05657d096d3d5c1673d8e1cd5f2aa2072eb /net-misc/rwbs/rwbs-0.27-r2.ebuild
parentnet-misc/rinetd: remove old version (diff)
downloadgentoo-97f09c02250fe75429e186aeabb2ddafc2e1fa25.tar.gz
gentoo-97f09c02250fe75429e186aeabb2ddafc2e1fa25.tar.bz2
gentoo-97f09c02250fe75429e186aeabb2ddafc2e1fa25.zip
net-misc/rwbs: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc/rwbs/rwbs-0.27-r2.ebuild')
-rw-r--r--net-misc/rwbs/rwbs-0.27-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/rwbs/rwbs-0.27-r2.ebuild b/net-misc/rwbs/rwbs-0.27-r2.ebuild
new file mode 100644
index 000000000000..a70ebf654693
--- /dev/null
+++ b/net-misc/rwbs/rwbs-0.27-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Roger Wilco base station"
+HOMEPAGE="http://rogerwilco.gamespy.com/"
+SRC_URI="http://games.gci.net/pub/VoiceOverIP/RogerWilco/rwbs_Linux_0_27.tar.gz"
+
+SLOT="0"
+LICENSE="Resounding GPL-2"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+# Everything is statically linked
+DEPEND=""
+
+S="${WORKDIR}"
+
+QA_PREBUILT="opt/bin/rwbs"
+
+src_install() {
+ dodoc README.TXT CHANGES.TXT
+ exeinto /opt/bin
+ doexe rwbs run_rwbs
+
+ # Put distribution into /usr/share/rwbs
+ insinto /usr/share/rwbs/
+ doins "${S}"/anotherpersonjoined "${S}"/helloandwelcome \
+ "${S}"/ifucanhearthis "${S}"/invitetestxmit "${S}"/join?.rwc \
+ "${S}"/plsstartagame "${S}"/thisisatestmsg
+
+ newconfd "${FILESDIR}"/rwbs.conf rwbs
+ newinitd "${FILESDIR}"/rwbs.rc rwbs
+}