summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMoritz Schlarb <schlarbm@uni-mainz.de>2017-03-13 15:01:51 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-04-13 23:20:36 +0200
commit19f55131adfd99dedbcd0d6cbd021c8e34849695 (patch)
tree67f99f687e2ad011e724b08396979666bcfae345 /net-misc/seafile
parentnet-libs/ccnet: new ebuild. (diff)
downloadgentoo-19f55131adfd99dedbcd0d6cbd021c8e34849695.tar.gz
gentoo-19f55131adfd99dedbcd0d6cbd021c8e34849695.tar.bz2
gentoo-19f55131adfd99dedbcd0d6cbd021c8e34849695.zip
net-misc/seafile: new ebuild.
File syncing and sharing software with file encryption and group sharing. Gentoo-Bug: https://bugs.gentoo.org/499698 Closes: https://github.com/gentoo/gentoo/pull/4198
Diffstat (limited to 'net-misc/seafile')
-rw-r--r--net-misc/seafile/Manifest1
-rw-r--r--net-misc/seafile/metadata.xml11
-rw-r--r--net-misc/seafile/seafile-6.0.4.ebuild36
3 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/seafile/Manifest b/net-misc/seafile/Manifest
new file mode 100644
index 000000000000..d73cd6b18f4e
--- /dev/null
+++ b/net-misc/seafile/Manifest
@@ -0,0 +1 @@
+DIST seafile-6.0.4.tar.gz 454474 SHA256 b3919bff1e0f974483df129e500868332e752dec6380556839e006bf9d5b425e SHA512 ca6b056238cf11c97c587cf353df2c0a820ecf8ea0faa23da008c6ea1ba731b41fe01d0142aa9406aa975e8386f68afe1cd76616c02a755d7a06a46596b30558 WHIRLPOOL 4ae21ef95484da8110ba6ef834465918dd7592d8931bf1f78e1a7934fe03352b0e799e75074aaa7563b724fe51ebd7b30df1fa8b40f92c2c9bbe793e9669eea0
diff --git a/net-misc/seafile/metadata.xml b/net-misc/seafile/metadata.xml
new file mode 100644
index 000000000000..5b95006282eb
--- /dev/null
+++ b/net-misc/seafile/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>moschlar@metalabs.de</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-misc/seafile/seafile-6.0.4.ebuild b/net-misc/seafile/seafile-6.0.4.ebuild
new file mode 100644
index 000000000000..a59144f17ddd
--- /dev/null
+++ b/net-misc/seafile/seafile-6.0.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+inherit autotools python-single-r1 vala
+
+DESCRIPTION="File syncing and sharing software with file encryption and group sharing"
+HOMEPAGE="https://github.com/haiwen/seafile/ http://www.seafile.com/"
+SRC_URI="https://github.com/haiwen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ net-libs/libsearpc[${PYTHON_USEDEP}]
+ =net-libs/ccnet-${PV}[${PYTHON_USEDEP}]
+ >=dev-libs/glib-2.16.0:2
+ >=dev-libs/libevent-2.0
+ >=dev-libs/jansson-2.2.1
+ >=sys-libs/zlib-1.2.0
+ >=net-misc/curl-7.17
+ dev-libs/openssl:0=
+ dev-db/sqlite:3"
+DEPEND="${RDEPEND}
+ $(vala_depend)"
+
+src_prepare() {
+ default
+ sed -i -e 's/valac /${VALAC} /' lib/Makefile.am || die
+ eautoreconf
+ vala_src_prepare
+}