summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Retornaz <gentoo@retornaz.com>2021-01-11 19:41:23 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-01-24 10:09:04 +0200
commitd74650f4259df39634bb6cf34cccad1b7c43cd4c (patch)
treeb57e34f60cc0d2f4d718d04a6d6b82ba9bed7943 /net-misc/seafile
parentx11-themes/e-flat-theme: remove old (diff)
downloadgentoo-d74650f4259df39634bb6cf34cccad1b7c43cd4c.tar.gz
gentoo-d74650f4259df39634bb6cf34cccad1b7c43cd4c.tar.bz2
gentoo-d74650f4259df39634bb6cf34cccad1b7c43cd4c.zip
net-misc/seafile: version bump to 8.0.1
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc/seafile')
-rw-r--r--net-misc/seafile/Manifest1
-rw-r--r--net-misc/seafile/seafile-8.0.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/seafile/Manifest b/net-misc/seafile/Manifest
index 284ee172adde..389c4db13764 100644
--- a/net-misc/seafile/Manifest
+++ b/net-misc/seafile/Manifest
@@ -1,2 +1,3 @@
DIST seafile-7.0.10.tar.gz 707294 BLAKE2B 7f31d09480a7be09c957a79442bc0c952a4b3802fe17d660cb4ae7d157fcb656280751ed5033e399a705fc24c8b0a232e55e5f289792bdb69abec304c85d3473 SHA512 6c5870e75d52f4409fc6f7e3884d3e9208693997b25a6347980a8d164ec6a3348f4b3f5a532f11b9221822aa0ec9125b9d9af8ba7abc4d392cd5b5f602df9289
DIST seafile-7.0.9.tar.gz 706859 BLAKE2B 2cbd12bfdda9c2cc13d38233a56d0d2f52ad04e03bd14c90c6ff086756fb7ab4f63319906030f9a5f4ec2625dbe23b2892c069f2b5d50c6997b23deaf2cb61d7 SHA512 4c87e7a4a6a4cef631cbfbeb1bde3c8c9e0915d5fe4597d5b3a4b8aa15e9650e97b51ee6a3b0bae4d235ec53149dca01aed7acd704da593c97da0a17e352a75d
+DIST seafile-8.0.1.tar.gz 731105 BLAKE2B ac4b79112e40196cce2dbc64bb94a852b3f81ea08e0a833d45a297c02f5f66432345647b9a34aef67d8108d16eb5e3648002a070bb556a70be63b8c0314af9bb SHA512 dd6366c06bfa25f16f5d3b2ef83b39b5886e834697891c274a3b4eafec3aabf72858dd4d341452e8d4fb8cd1166d30bb8a783dddb4370c02526e3a00ed9fdb3c
diff --git a/net-misc/seafile/seafile-8.0.1.ebuild b/net-misc/seafile/seafile-8.0.1.ebuild
new file mode 100644
index 000000000000..34ef04ab9f88
--- /dev/null
+++ b/net-misc/seafile/seafile-8.0.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{6,7,8,9})
+
+WANT_AUTOMAKE=1.16
+
+inherit autotools python-single-r1 vala
+
+DESCRIPTION="File syncing and sharing software with file encryption and group sharing"
+HOMEPAGE="https://www.seafile.com/ https://github.com/haiwen/seafile/"
+SRC_URI="https://github.com/haiwen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+-with-openssl-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ net-libs/libsearpc[${PYTHON_SINGLE_USEDEP}]
+ dev-libs/glib:2
+ dev-libs/libevent
+ dev-libs/jansson
+ $(python_gen_cond_dep '
+ dev-python/future[${PYTHON_MULTI_USEDEP}]
+ ')
+ sys-libs/zlib
+ net-misc/curl
+ !libressl? ( dev-libs/openssl:= )
+ libressl? ( dev-libs/libressl:= )
+ dev-db/sqlite:3"
+DEPEND="${RDEPEND}
+ $(vala_depend)"
+
+src_prepare() {
+ default
+ sed -i -e 's/valac /${VALAC} /' lib/Makefile.am || die
+ eautoreconf
+ vala_src_prepare
+}
+
+src_install() {
+ default
+ # Remove unnecessary .la files, as recommended by ltprune.eclass
+ find "${ED}" -name '*.la' -o -name '*.a' -delete || die
+ python_fix_shebang "${ED}"/usr/bin
+}