summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/secpanel/secpanel-0.6.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/secpanel/secpanel-0.6.1.ebuild')
-rw-r--r--net-misc/secpanel/secpanel-0.6.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/secpanel/secpanel-0.6.1.ebuild b/net-misc/secpanel/secpanel-0.6.1.ebuild
new file mode 100644
index 000000000000..1125bcb886ce
--- /dev/null
+++ b/net-misc/secpanel/secpanel-0.6.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="Graphical frontend for managing and running SSH and SCP connections"
+HOMEPAGE="http://themediahost.de/secpanel/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 sparc x86"
+IUSE="gif"
+
+DEPEND="!gif? ( || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] ) )"
+
+RDEPEND="virtual/ssh dev-lang/tk"
+
+S=${WORKDIR}/usr/local
+
+src_prepare() {
+ # install arch indep stuff in /usr/share instead of /usr/lib*
+ sed -i -e '/set libdir/s:../lib:../share:' bin/secpanel || die
+
+ # fix the version
+ sed -i -e "/set spversion/s:0.6.0:${PV}:" bin/secpanel || die
+
+ # optionally remove gifs...
+ if ! use gif; then
+ einfo "Setting secpanel to use PPM images"
+ sed -i -e 's/\.gif/\.ppm/g' bin/secpanel || die
+
+ einfo "Converting all GIF images to PPM format..."
+ for i in $(find lib/secpanel/images -name "*.gif") ; do
+ einfo "convert ${i} => ${i//.gif/.ppm}"
+ convert "${i}" "ppm:${i//.gif/.ppm}" || die
+ rm -v "${i}" || die
+ done
+ fi
+}
+
+src_install() {
+ dobin bin/secpanel || die
+
+ insinto /usr/share/secpanel
+ doins -r lib/secpanel/{*.{tcl,config,profile,wait,txt,sh},images,spdistkey} || die
+}