summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/ser2net
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/ser2net')
-rw-r--r--net-misc/ser2net/Manifest3
-rw-r--r--net-misc/ser2net/files/ser2net-2.7-b230400.diff20
-rw-r--r--net-misc/ser2net/files/ser2net.confd27
-rw-r--r--net-misc/ser2net/files/ser2net.initd55
-rw-r--r--net-misc/ser2net/metadata.xml12
-rw-r--r--net-misc/ser2net/ser2net-2.10.0.ebuild32
-rw-r--r--net-misc/ser2net/ser2net-2.7-r1.ebuild41
-rw-r--r--net-misc/ser2net/ser2net-2.9.1.ebuild32
8 files changed, 222 insertions, 0 deletions
diff --git a/net-misc/ser2net/Manifest b/net-misc/ser2net/Manifest
new file mode 100644
index 000000000000..40c53ce3d0a0
--- /dev/null
+++ b/net-misc/ser2net/Manifest
@@ -0,0 +1,3 @@
+DIST ser2net-2.10.0.tar.gz 364322 SHA256 98f6193225338e25f35302fef5e1f16688693ed43e7b3c3e9e09187eb54547ac SHA512 dd3e37619b10d8bf20d738e90c253bc2d109e0a57ee9f3a8b2a85a69399afa5a8459a4602b2856f0b655427023a36c78330851bf7f8d8da0f28d1fe22c1d5e10 WHIRLPOOL 34ed707308c71d5969e653e01f61e047f17669d34e15807675af11f4356cb77fe18d4f4d9041a449c3c2686c2d1dde0f928ea73e3936967a2db5d91838b41ecc
+DIST ser2net-2.7.tar.gz 355064 SHA256 620265d5d4a59714dbb8645d1698a34135077c735e018ef040d57e7d3a621088 SHA512 39ee99031fad45ea8eeeb9e8bec343e8d6bd58c818f56ec01a05c50ef6d8ed845c6521a6d4a306671ed26959bd2df5c0b29a6b4399103815923cf958c1891c16 WHIRLPOOL 1bb875c7603aaf6ef811dfe6404797a1e9ec152d7b1fa70c26c84e341ad7ade11674bf6e0d0edd978a43189c2f0a5757a7809b4a33d0bd0fd1d5e143452ecac5
+DIST ser2net-2.9.1.tar.gz 357820 SHA256 fdee1e69903cf409bdc6f32403a566cbc6006aa9e2a4d6f8f12b90dfd5ca0d0e SHA512 9fd0efc853993b70c0c632a7059df7a04c832f85491194c49dd8b384e1bb1a576ed9cfe28088cc181a2f7084c88dc6ef6dabbc4ead5ad9339a7becebaa6fb8e7 WHIRLPOOL 0601f3d7d15abbbe25dd3970d3e78f289efd399ba8723b53589e956ed1d8a3a7c9dec9197b26527331e7ad5ffbb8042852d1d4fb36fb500d93ccf736cd25acbf
diff --git a/net-misc/ser2net/files/ser2net-2.7-b230400.diff b/net-misc/ser2net/files/ser2net-2.7-b230400.diff
new file mode 100644
index 000000000000..5e567c118eac
--- /dev/null
+++ b/net-misc/ser2net/files/ser2net-2.7-b230400.diff
@@ -0,0 +1,20 @@
+--- ser2net-2.7.orig/devcfg.c 2009-10-23 14:23:25.000000000 +0200
++++ ser2net-2.7/devcfg.c 2012-07-17 21:03:49.708603108 +0200
+@@ -113,6 +113,9 @@
+ } else if (strcmp(pos, "115200") == 0) {
+ cfsetospeed(termctl, B115200);
+ cfsetispeed(termctl, B115200);
++ } else if (strcmp(pos, "230400") == 0) {
++ cfsetospeed(termctl, B230400);
++ cfsetispeed(termctl, B230400);
+ } else if (strcmp(pos, "1STOPBIT") == 0) {
+ termctl->c_cflag &= ~(CSTOPB);
+ } else if (strcmp(pos, "2STOPBITS") == 0) {
+@@ -190,6 +193,7 @@
+ case B38400: str = "38400"; break;
+ case B57600: str = "57600"; break;
+ case B115200: str = "115200"; break;
++ case B230400: str = "230400"; break;
+ default: str = "unknown speed";
+ }
+ return str;
diff --git a/net-misc/ser2net/files/ser2net.confd b/net-misc/ser2net/files/ser2net.confd
new file mode 100644
index 000000000000..c66685159348
--- /dev/null
+++ b/net-misc/ser2net/files/ser2net.confd
@@ -0,0 +1,27 @@
+# Config file for /etc/init.d/ser2net
+
+# Set the configuration file to one other than the default of /etc/ser2net.conf
+#
+#CONFIG_FILE="/etc/ser2net.conf"
+
+# Enables the control port and sets the TCP port to listen to for the control port.
+# A port number may be of the form [host,]port, such as 127.0.0.1,2000 or localhost,2000.
+# If this is specified, it will only bind to the IP address specified for the port.
+# Otherwise, it will bind to all the addresses on the machine.
+#
+#CONTROL_PORT=""
+
+# Cisco IOS uses a different mechanism for specifying the baud rates than the mechanism
+# described in RFC2217. This option sets the IOS version of setting the baud rates.
+# The default is RFC2217s.
+#
+#CISCO_IOS="yes"
+
+# Enable or disable UUCP locking (default=yes)
+#
+#UUCP_LOCKS="no"
+
+# see the ser2net(8) manual page for additional options you can configure here
+#
+#EXTRA_OPTS=""
+
diff --git a/net-misc/ser2net/files/ser2net.initd b/net-misc/ser2net/files/ser2net.initd
new file mode 100644
index 000000000000..c3010b90446c
--- /dev/null
+++ b/net-misc/ser2net/files/ser2net.initd
@@ -0,0 +1,55 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+description="Serial to network proxy (${RC_SVCNAME#*.})"
+pidfile="/var/run/${RC_SVCNAME}.pid"
+command="/usr/sbin/ser2net"
+name="${RC_SVCNAME}"
+
+extra_started_commands="reload"
+description_reload="Reread configuration file and make the appropriate changes"
+start_stop_daemon_args="--quiet --exec ${command} --name ${name} --pidfile ${pidfile}"
+
+depend() {
+ use logger
+ need net
+}
+
+config_check() {
+ command_args="${EXTRA_OPTS}"
+ CONFIG_FILE_DEFAULT="/etc/ser2net.conf"
+
+ yesno "${CISCO_IOS:-no}" && command_args="${SER2NET_OPTS} -b"
+ yesno "${UUCP_LOCKS:-yes}" || command_args="${command_args} -u"
+ [ -z "${CONFIG_FILE}" ] && CONFIG_FILE="${CONFIG_FILE_DEFAULT}"
+ [ -n "${CONTROL_PORT}" ] && command_args="${command_args} -p ${CONTROL_PORT}"
+ [ "${CONFIG_FILE}" != "${CONFIG_FILE_DEFAULT}" ] && command_args="${command_args} -c ${CONFIG_FILE}"
+
+ if [ ! -f "${CONFIG_FILE}" ]; then
+ eerror "Please create ${CONFIG_FILE}"
+ eerror "Sample conf: ${CONFIG_FILE_DEFAULT}.dist"
+ return 1
+ fi
+ return 0
+}
+
+start() {
+ config_check || return ${?}
+ ebegin "Starting ${description}"
+ start-stop-daemon --start ${start_stop_daemon_args} -- ${command_args} -P "${pidfile}"
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping ${description}"
+ start-stop-daemon --stop ${start_stop_daemon_args}
+ eend ${?}
+}
+
+reload() {
+ ebegin "Reloading ${description}"
+ start-stop-daemon --signal HUP ${start_stop_daemon_args}
+ eend ${?}
+}
diff --git a/net-misc/ser2net/metadata.xml b/net-misc/ser2net/metadata.xml
new file mode 100644
index 000000000000..fa93e6debbf7
--- /dev/null
+++ b/net-misc/ser2net/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>brendan@horan.hk</email>
+ <name>Brendan Horan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">ser2net</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/ser2net/ser2net-2.10.0.ebuild b/net-misc/ser2net/ser2net-2.10.0.ebuild
new file mode 100644
index 000000000000..d7f9b2350694
--- /dev/null
+++ b/net-misc/ser2net/ser2net-2.10.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Serial To Network Proxy"
+SRC_URI="mirror://sourceforge/ser2net/${P}.tar.gz"
+HOMEPAGE="http://sourceforge.net/projects/ser2net"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )"
+RDEPEND="${DEPEND}"
+
+IUSE="tcpd"
+
+src_configure() {
+ econf $(use_with tcpd tcp-wrappers) --with-uucp-locking
+}
+
+src_install () {
+ default
+
+ insinto /etc
+ newins ${PN}.conf ${PN}.conf.dist
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}
diff --git a/net-misc/ser2net/ser2net-2.7-r1.ebuild b/net-misc/ser2net/ser2net-2.7-r1.ebuild
new file mode 100644
index 000000000000..a9b8ccba3429
--- /dev/null
+++ b/net-misc/ser2net/ser2net-2.7-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit base autotools
+
+DESCRIPTION="Serial To Network Proxy"
+SRC_URI="mirror://sourceforge/ser2net/${P}.tar.gz"
+HOMEPAGE="http://sourceforge.net/projects/ser2net"
+
+KEYWORDS="~amd64 ppc x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )"
+RDEPEND="${DEPEND}"
+
+IUSE="tcpd"
+
+PATCHES=( "${FILESDIR}/${P}-b230400.diff" )
+DOCS=( "AUTHORS" "NEWS" "README" "ChangeLog" )
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ local myopts="$(use_with tcpd tcp-wrappers) --with-uucp-locking"
+ econf ${myopts} || die "econf failed"
+}
+
+src_install () {
+ base_src_install
+ insinto /etc
+ newins ${PN}.conf ${PN}.conf.dist
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}
diff --git a/net-misc/ser2net/ser2net-2.9.1.ebuild b/net-misc/ser2net/ser2net-2.9.1.ebuild
new file mode 100644
index 000000000000..5c6a6a91cba9
--- /dev/null
+++ b/net-misc/ser2net/ser2net-2.9.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Serial To Network Proxy"
+SRC_URI="mirror://sourceforge/ser2net/${P}.tar.gz"
+HOMEPAGE="http://sourceforge.net/projects/ser2net"
+
+KEYWORDS="~amd64 ppc x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )"
+RDEPEND="${DEPEND}"
+
+IUSE="tcpd"
+
+src_configure() {
+ econf $(use_with tcpd tcp-wrappers) --with-uucp-locking
+}
+
+src_install () {
+ default
+
+ insinto /etc
+ newins ${PN}.conf ${PN}.conf.dist
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}