summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-06-24 17:18:07 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-06 23:47:54 +0200
commit784449da19027b79ac828230f6c87d01ab0d1430 (patch)
tree4c287b52e59a62de49369e38534b5458df39d3b2 /net-misc/snarf
parentnet-misc/snarf: use HTTPs (diff)
downloadgentoo-784449da19027b79ac828230f6c87d01ab0d1430.tar.gz
gentoo-784449da19027b79ac828230f6c87d01ab0d1430.tar.bz2
gentoo-784449da19027b79ac828230f6c87d01ab0d1430.zip
net-misc/snarf: EAPI7, improve ebuild
Diffstat (limited to 'net-misc/snarf')
-rw-r--r--net-misc/snarf/snarf-7.0-r4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/snarf/snarf-7.0-r4.ebuild b/net-misc/snarf/snarf-7.0-r4.ebuild
new file mode 100644
index 000000000000..dacf70a7a6c3
--- /dev/null
+++ b/net-misc/snarf/snarf-7.0-r4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Small and fast CLI resource grabber for http, gopher, finger, ftp"
+HOMEPAGE="https://www.xach.com/snarf/"
+SRC_URI="https://www.xach.com/snarf/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/snarf-basename-patch.diff
+ "${FILESDIR}"/snarf-unlink-empty.diff
+ "${FILESDIR}"/snarf-fix-off-by-ones.diff
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin snarf
+ doman snarf.1
+ dodoc ChangeLog README TODO
+}
+
+pkg_postinst() {
+ elog 'To use snarf with portage, try these settings in your make.conf'
+ elog
+ elog ' FETCHCOMMAND="/usr/bin/snarf -b \${URI} \${DISTDIR}/\${FILE}"'
+ elog ' RESUMECOMMAND="/usr/bin/snarf -rb \${URI} \${DISTDIR}/\${FILE}"'
+}