summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/sslwrap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/sslwrap')
-rw-r--r--net-misc/sslwrap/Manifest1
-rw-r--r--net-misc/sslwrap/files/sslwrap-2.0.6-build.patch147
-rw-r--r--net-misc/sslwrap/metadata.xml7
-rw-r--r--net-misc/sslwrap/sslwrap-2.0.6-r2.ebuild35
4 files changed, 190 insertions, 0 deletions
diff --git a/net-misc/sslwrap/Manifest b/net-misc/sslwrap/Manifest
new file mode 100644
index 000000000000..ba90fd976a41
--- /dev/null
+++ b/net-misc/sslwrap/Manifest
@@ -0,0 +1 @@
+DIST sslwrap-2.0.6.tar.gz 21170 SHA256 596a1bf61a457662e754b9fcfec6b3df7fb2f6c88498bd76ef8027f08c3af336 SHA512 627c25bdf45245f9b3e8d03272fc46a0ef8d1c356e2b7990898b07267c2bbb28efd13d5ca97d330ce7369eedd2d20b5fa781f2e1a00ac732407e06d0b3a8890d WHIRLPOOL 8d3c6843413d8a77830a3533aa972cc676bf2aa934cb259b3b04a485aedc052551914668efbcff071fcd50fd0f21ea9cd57c702f95d803f06315d92e79fafc89
diff --git a/net-misc/sslwrap/files/sslwrap-2.0.6-build.patch b/net-misc/sslwrap/files/sslwrap-2.0.6-build.patch
new file mode 100644
index 000000000000..a797c00b152c
--- /dev/null
+++ b/net-misc/sslwrap/files/sslwrap-2.0.6-build.patch
@@ -0,0 +1,147 @@
+http://bugs.gentoo.org/34151
+http://bugs.gentoo.org/146828
+http://bugs.gentoo.org/335001
+
+--- apps.h
++++ apps.h
+@@ -65,9 +65,9 @@
+ #include "../e_os.h"
+ #endif
+
+-#include OPENSSL"buffer.h"
+-#include OPENSSL"bio.h"
+-#include OPENSSL"crypto.h"
++#include "openssl/buffer.h"
++#include "openssl/bio.h"
++#include "openssl/crypto.h"
+ /*#include "progs.h"*/
+
+ #ifdef WIN16
+--- Makefile
++++ Makefile
+@@ -1,28 +1,9 @@
+-
+ SRC = s_server.c s_socket.c s_cb.c
+-
+-# For Solaris2.6
+-#EXTLIBS = -lxnet
+-
+-# Debug/Optimizations
+-#OPT = -g
+-OPT = -O2
+-
+-# Define
++LIBS = `pkg-config --libs openssl`
+ OPENSSL="\"openssl/\""
+-#OPENSSL=""
+
+-all :
+- gcc -o sslwrap ${SRC} ${OPT} -DFLAT_INC -DOPENSSL=${OPENSSL} \
+- -L/usr/local/ssl/lib -lssl -lcrypto \
+- -I/usr/local/ssl/include \
+- ${EXTLIBS}
++all:
++ $(CC) $(LDFLAGS) $(CFLAGS) -o sslwrap ${SRC} -DFLAT_INC -DOPENSSL=${OPENSSL} ${LIBS}
+
+ clean:
+ rm -f sslwrap *.o *~
+-
+-
+-
+-
+-
+-
+--- s_cb.c
++++ s_cb.c
+@@ -63,9 +63,9 @@
+ #include "apps.h"
+ #undef NON_MAIN
+ #undef USE_SOCKETS
+-#include OPENSSL"err.h"
+-#include OPENSSL"x509.h"
+-#include OPENSSL"ssl.h"
++#include "openssl/err.h"
++#include "openssl/x509.h"
++#include "openssl/ssl.h"
+ #include "s_apps.h"
+
+ int verify_depth=0;
+--- s_server.c
++++ s_server.c
+@@ -121,14 +117,14 @@
+ #ifdef WIN16
+ #define APPS_WIN16
+ #endif
+-#include OPENSSL"lhash.h"
+-#include OPENSSL"bn.h"
++#include "openssl/lhash.h"
++#include "openssl/bn.h"
+ #define USE_SOCKETS
+ #include "apps.h"
+-#include OPENSSL"err.h"
+-#include OPENSSL"pem.h"
+-#include OPENSSL"x509.h"
+-#include OPENSSL"ssl.h"
++#include "err.h"
++#include "openssl/pem.h"
++#include "openssl/x509.h"
++#include "openssl/ssl.h"
+ #include "s_apps.h"
+
+ #ifndef NOPROTO
+@@ -468,7 +464,7 @@
+
+ if (bugs) SSL_CTX_set_options(ctx,SSL_OP_ALL);
+ if (hack) SSL_CTX_set_options(ctx,SSL_OP_NETSCAPE_DEMO_CIPHER_CHANGE_BUG);
+- if (hack) SSL_CTX_set_options(ctx,SSL_OP_NON_EXPORT_FIRST);
++ if (hack) SSL_CTX_set_options(ctx,SSL_OP_CIPHER_SERVER_PREFERENCE);
+
+ if (state) SSL_CTX_set_info_callback(ctx,apps_ssl_info_callback);
+
+@@ -622,7 +618,7 @@
+ #endif /*NO_EXEC*/
+ }
+
+- if ((buf=malloc(BUFSIZZ)) == NULL)
++ if ((buf=CRYPTO_malloc(BUFSIZZ,__FILE__,__LINE__)) == NULL)
+ {
+ BIO_printf(bio_err,"out of memory\n");
+ goto err;
+@@ -729,7 +725,7 @@
+ if (buf != NULL)
+ {
+ memset(buf,0,BUFSIZZ);
+- free(buf);
++ CRYPTO_free(buf);
+ }
+
+ return(ret);
+--- s_socket.c
++++ s_socket.c
+@@ -67,7 +67,7 @@
+ #undef USE_SOCKETS
+ #undef NON_MAIN
+ #include "s_apps.h"
+-#include OPENSSL"ssl.h"
++#include "openssl/ssl.h"
+
+ #ifndef NOPROTO
+ static struct hostent *GetHostByName(char *name);
+@@ -305,7 +305,7 @@
+ return(0);
+ }
+ i=(*cb)(name,sock, sock);
+- if (name != NULL) free(name);
++ if (name != NULL) CRYPTO_free(name);
+ SHUTDOWN(sock);
+ if (i < 0)
+ {
+@@ -410,7 +410,7 @@
+ }
+ else
+ {
+- if ((*host=(char *)malloc(strlen(h1->h_name)+1)) == NULL)
++ if ((*host=(char *)CRYPTO_malloc(strlen(h1->h_name)+1,__FILE__,__LINE__)) == NULL)
+ {
+ perror("Malloc");
+ return(0);
diff --git a/net-misc/sslwrap/metadata.xml b/net-misc/sslwrap/metadata.xml
new file mode 100644
index 000000000000..1470e032181b
--- /dev/null
+++ b/net-misc/sslwrap/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-misc/sslwrap/sslwrap-2.0.6-r2.ebuild b/net-misc/sslwrap/sslwrap-2.0.6-r2.ebuild
new file mode 100644
index 000000000000..2adcb3755657
--- /dev/null
+++ b/net-misc/sslwrap/sslwrap-2.0.6-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="TSL/SSL - Port Wrapper"
+HOMEPAGE="http://www.rickk.com/sslwrap/index.htm"
+SRC_URI="http://www.rickk.com/${PN}/${PN}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="SSLeay"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+RDEPEND="dev-libs/openssl:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}${PV//.}
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_install() {
+ dosbin ${PN}
+ dodoc README
+ dohtml -r .
+}