summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2018-02-07 22:18:29 +0100
committerAmy Liffey <amynka@gentoo.org>2018-02-07 22:20:57 +0100
commit129c10cbe13035d2dda5face949e47a43b0bc116 (patch)
tree1e213c7434e5326313aa327605224d689588a249 /net-misc/sstp-client
parentnet-analyzer/wireshark: Version 2.5.0. (diff)
downloadgentoo-129c10cbe13035d2dda5face949e47a43b0bc116.tar.gz
gentoo-129c10cbe13035d2dda5face949e47a43b0bc116.tar.bz2
gentoo-129c10cbe13035d2dda5face949e47a43b0bc116.zip
net-misc/sstp-client: version bump 1.0.11
Suggested-by: mjeveritt Closes: https://github.com/gentoo/gentoo/pull/5618 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'net-misc/sstp-client')
-rw-r--r--net-misc/sstp-client/Manifest1
-rw-r--r--net-misc/sstp-client/files/sstp-client-1.0.11-fix-example.patch16
-rw-r--r--net-misc/sstp-client/files/sstp-client-1.0.11-remove-network-test.patch11
-rw-r--r--net-misc/sstp-client/sstp-client-1.0.11.ebuild56
4 files changed, 84 insertions, 0 deletions
diff --git a/net-misc/sstp-client/Manifest b/net-misc/sstp-client/Manifest
index ea6208e58774..13f6d60ca4c1 100644
--- a/net-misc/sstp-client/Manifest
+++ b/net-misc/sstp-client/Manifest
@@ -1 +1,2 @@
DIST sstp-client-1.0.10.tar.gz 3012713 BLAKE2B 6b924c9fef4df26a9aa93dd5670cae4dbfe020f2c1bfc955f88f229414b5295864c25637bddf3b80d522dd514a4f3042522f9615fe660165b4417d6ea832e4bf SHA512 8f3e4b1b4d795015230b3a1b8aabf7d5fddd89be511bd6a59c22e5414520a392ba430f66f30aa2b982f084955e0085b0ea66d5acf5fd00414dc37c2c52a78cb7
+DIST sstp-client-1.0.11.tar.gz 3035707 BLAKE2B f534060bc47599a372b95b25400e7cb09911eb0216b11faa5bdcf0241d7c5caabd7df6065e58dff2b6b1f6c4e416499f58f92900da024d0ad0684aa3cc4d9abd SHA512 d22b03f1bc2d5215def6ce198d6e81b08a5cebc4db9de269bc2e66785845521f0606a96af5d9d257dcf78addafee8ad3d942de0075f47038fbfe0b5051002487
diff --git a/net-misc/sstp-client/files/sstp-client-1.0.11-fix-example.patch b/net-misc/sstp-client/files/sstp-client-1.0.11-fix-example.patch
new file mode 100644
index 000000000000..f2b81174fc1a
--- /dev/null
+++ b/net-misc/sstp-client/files/sstp-client-1.0.11-fix-example.patch
@@ -0,0 +1,16 @@
+--- a/Makefile.am 2018-02-07 21:51:10.451717813 +0100
++++ b/Makefile.am 2018-02-07 21:54:43.811708840 +0100
+@@ -7,11 +7,11 @@
+ include \
+ src
+
+-docdir = $(datadir)/doc/@PACKAGE@
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = sstp-client-1.0.pc
+
+-doc_DATA = \
++examplesdir = $(docdir)/examples
++examples_DATA = \
+ sstp-test.example \
+ sstp-test-nopty.example
+
diff --git a/net-misc/sstp-client/files/sstp-client-1.0.11-remove-network-test.patch b/net-misc/sstp-client/files/sstp-client-1.0.11-remove-network-test.patch
new file mode 100644
index 000000000000..d6868f3e26bd
--- /dev/null
+++ b/net-misc/sstp-client/files/sstp-client-1.0.11-remove-network-test.patch
@@ -0,0 +1,11 @@
+--- a/src/Makefile.am 2018-02-07 21:42:37.755739374 +0100
++++ b/src/Makefile.am 2018-02-07 21:45:28.855732178 +0100
+@@ -23,7 +23,7 @@
+ utest_fcs \
+ utest_route
+
+-TESTS= $(check_PROGRAMS)
++TESTS= utest_task utest_cmac utest_chap utest_fcs
+
+ sstpc_SOURCES = \
+ sstp-client.c \
diff --git a/net-misc/sstp-client/sstp-client-1.0.11.ebuild b/net-misc/sstp-client/sstp-client-1.0.11.ebuild
new file mode 100644
index 000000000000..07ce4377c768
--- /dev/null
+++ b/net-misc/sstp-client/sstp-client-1.0.11.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools linux-info user
+
+DESCRIPTION="A client implementation of Secure Socket Tunneling Protocol (SSTP)"
+HOMEPAGE="http://sstp-client.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sstp-client/${P}.tar.gz"
+
+LICENSE="GPL-2+-with-openssl-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="static"
+
+RDEPEND=">=dev-libs/libevent-2.0.10
+ dev-libs/openssl:0=
+ net-dialup/ppp:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+CONFIG_CHECK="~NETFILTER_NETLINK"
+
+PATCHES=( "${FILESDIR}/${P}-remove-network-test.patch"
+ "${FILESDIR}/${P}-fix-example.patch"
+)
+DOCS=( AUTHORS ChangeLog DEVELOPERS NEWS README TODO USING )
+
+pkg_setup() {
+ enewgroup sstpc
+ enewuser sstpc -1 -1 -1 sstpc
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local PPPD_VER="$(best_version net-dialup/ppp)"
+ PPPD_VER=${PPPD_VER#*/*-} # reduce it to ${PV}-${PR}
+ PPPD_VER=${PPPD_VER%%[_-]*} # main version without beta/pre/patch/revision
+ econf \
+ --enable-ppp-plugin \
+ --enable-group=sstpc \
+ --enable-user=sstpc \
+ --with-pppd-plugin-dir="/usr/$(get_libdir)/pppd/${PPPD_VER}" \
+ --with-runtime-dir="/run/sstpc" \
+ $(use_enable static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}