summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-09-23 16:37:23 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-09-23 17:07:21 -0400
commit1576b56cab9ced04ccf165b9b7335a466cd5ba66 (patch)
tree2d19d2cfe2570f7ad5424ffc52ef40658cd5a813 /net-misc/stunnel
parentnet-misc/tor: version bump to 0.2.8.8, remove 0.2.8.6 (diff)
downloadgentoo-1576b56cab9ced04ccf165b9b7335a466cd5ba66.tar.gz
gentoo-1576b56cab9ced04ccf165b9b7335a466cd5ba66.tar.bz2
gentoo-1576b56cab9ced04ccf165b9b7335a466cd5ba66.zip
net-misc/stunnel: version bump to 5.36
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-misc/stunnel')
-rw-r--r--net-misc/stunnel/Manifest1
-rw-r--r--net-misc/stunnel/stunnel-5.36.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/net-misc/stunnel/Manifest b/net-misc/stunnel/Manifest
index e5f5997b53a9..bcd0613a42af 100644
--- a/net-misc/stunnel/Manifest
+++ b/net-misc/stunnel/Manifest
@@ -2,3 +2,4 @@ DIST stunnel-5.24.tar.gz 631730 SHA256 ab2e5a1034d422951ddad21b572eb7fa8efb4c4ce
DIST stunnel-5.30.tar.gz 638771 SHA256 7d6eb389f6a1954b3bcf6c71d4ae3c5f9dde1990dd0b9e0cb1c7caf138d60570 SHA512 66bb610241e70881f8b14bfaec712a48361ec43a631db8b38ea0c94547fa184896e2d1fbbce52eb13c65411aa1ca10b3e9e42bde1651b38a5d551504b3b38f3c WHIRLPOOL 6b375be08c52088de065028d4d2e4d99301dbeb3a6771bbfe19f715d1dd9f7ccf893b87b973dbb19bfc5decf7f6e487322d857e04fdccdd535140ebecef358f8
DIST stunnel-5.34.tar.gz 644677 SHA256 786111168a84a5a01188dddfcecb37d8c69a4c725dc3b476fbbd294e86741a55 SHA512 32edd2e3461536a35b150068720492a84d3174f8ede46b3d79e42a1c00e5096ea631dae41072c982c95b46ce3cb9dcf8dd1e48a4c429e94933d30b12c21d1181 WHIRLPOOL fc0d22cdb8a9bf4c5bdbd12c14d09d2fbb31ec3d16e5b9d32436980aaedd321cdffed031ced9b93b04bc1f97111d7379f8473400b44064abf417fb65d846ff18
DIST stunnel-5.35.tar.gz 645148 SHA256 ffa386ae4c825f35f35157c285e7402a6d58779ad8c3822f74a9d355b54aba1d SHA512 cdec7ddafbfac4a1d420704baec72fedbd655871137ec8283c066203c0859019c6e11ce00647e5b471a019409e4eb5e9525166eddd7ddffa25055b95c0cacd9e WHIRLPOOL 9d3c4538827ce94a27ad6922a2c4e38192ec8a3d23e0059e328651eaadf7c0696c8751174553bce801a2e940c34c164d871d76b7b623a59133cd0a5c6b00aed2
+DIST stunnel-5.36.tar.gz 645205 SHA256 eb8952fcfdfcdf5056a1f1a78e1ec5014b819c5f5f7599b924dc4490ffe4b5ea SHA512 663dd155aab17b628fd1ef8ae1c604efc0cdf026566e98fbff16ba4da5b12b06cd6801bf4f604a9b2ea98d993c184ce97c63c1f716fa86b5e630e5fd504e3317 WHIRLPOOL 12f95a119b840b6afdcaf4d41ee325896bc89feda9ed172651dee1b52a3231fe1599c8fb6c69c1a0f93b342a3b785fb3d002a94a31b14678052313f224c48d0e
diff --git a/net-misc/stunnel/stunnel-5.36.ebuild b/net-misc/stunnel/stunnel-5.36.ebuild
new file mode 100644
index 000000000000..53ee300c3c49
--- /dev/null
+++ b/net-misc/stunnel/stunnel-5.36.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit ssl-cert eutils multilib systemd user
+
+DESCRIPTION="TLS/SSL - Port Wrapper"
+HOMEPAGE="http://www.stunnel.org/index.html"
+SRC_URI="ftp://ftp.stunnel.org/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ http://www.usenix.org.uk/mirrors/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ http://ftp.nluug.nl/pub/networking/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ http://www.namesdir.com/mirrors/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ http://stunnel.cybermirror.org/archive/${PV%%.*}.x/${P}.tar.gz
+ http://mirrors.zerg.biz/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ ftp://mirrors.go-parts.com/stunnel/archive/${PV%%.*}.x/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="ipv6 libressl selinux stunnel3 tcpd"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )"
+RDEPEND="${DEPEND}
+ stunnel3? ( dev-lang/perl )
+ selinux? ( sec-policy/selinux-stunnel )"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup stunnel
+ enewuser stunnel -1 -1 -1 stunnel
+}
+
+src_prepare() {
+ # Hack away generation of certificate
+ sed -i -e "s/^install-data-local:/do-not-run-this:/" \
+ tools/Makefile.in || die "sed failed"
+
+ # libressl compat
+ epatch "${FILESDIR}"/stunnel-compat-libressl.patch
+
+ echo "CONFIG_PROTECT=\"/etc/stunnel/stunnel.conf\"" > "${T}"/20stunnel
+}
+
+src_configure() {
+ econf \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ $(use_enable ipv6) \
+ $(use_enable tcpd libwrap) \
+ --with-ssl="${EPREFIX}"/usr \
+ --disable-fips
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm -rf "${ED}"/usr/share/doc/${PN}
+ rm -f "${ED}"/etc/stunnel/stunnel.conf-sample \
+ "${ED}"/usr/share/man/man8/stunnel.{fr,pl}.8
+ use stunnel3 || rm -f "${ED}"/usr/bin/stunnel3
+
+ # The binary was moved to /usr/bin with 4.21,
+ # symlink for backwards compatibility
+ dosym ../bin/stunnel /usr/sbin/stunnel
+
+ dodoc AUTHORS BUGS CREDITS PORTS README TODO ChangeLog
+ dohtml doc/stunnel.html doc/en/VNC_StunnelHOWTO.html tools/ca.html \
+ tools/importCA.html
+
+ insinto /etc/stunnel
+ doins "${FILESDIR}"/stunnel.conf
+ newinitd "${FILESDIR}"/stunnel-r1 stunnel
+
+ doenvd "${T}"/20stunnel
+
+ systemd_dounit "${S}/tools/stunnel.service"
+ systemd_newtmpfilesd "${FILESDIR}"/stunnel.tmpfiles.conf stunnel.conf
+}
+
+pkg_postinst() {
+ if [ ! -f "${EROOT}"/etc/stunnel/stunnel.key ]; then
+ install_cert /etc/stunnel/stunnel
+ chown stunnel:stunnel "${EROOT}"/etc/stunnel/stunnel.{crt,csr,key,pem}
+ chmod 0640 "${EROOT}"/etc/stunnel/stunnel.{crt,csr,key,pem}
+ fi
+
+ einfo "If you want to run multiple instances of stunnel, create a new config"
+ einfo "file ending with .conf in /etc/stunnel/. **Make sure** you change "
+ einfo "\'pid= \' with a unique filename."
+}