summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-12-04 17:52:27 +0100
committerMichał Górny <mgorny@gentoo.org>2018-12-04 17:53:40 +0100
commit73eb78b120e29dba2f8272bbdd4ae6dc17644eb1 (patch)
tree825c4bc92c6564701c524d51ad9f8843de0893ad /net-misc/tlsdate/tlsdate-0.0.13.ebuild
parentnet-analyzer/w3af: Remove last-rited pkg (diff)
downloadgentoo-73eb78b120e29dba2f8272bbdd4ae6dc17644eb1.tar.gz
gentoo-73eb78b120e29dba2f8272bbdd4ae6dc17644eb1.tar.bz2
gentoo-73eb78b120e29dba2f8272bbdd4ae6dc17644eb1.zip
net-misc/tlsdate: Remove last-rited pkg
Closes: https://bugs.gentoo.org/637286 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-misc/tlsdate/tlsdate-0.0.13.ebuild')
-rw-r--r--net-misc/tlsdate/tlsdate-0.0.13.ebuild76
1 files changed, 0 insertions, 76 deletions
diff --git a/net-misc/tlsdate/tlsdate-0.0.13.ebuild b/net-misc/tlsdate/tlsdate-0.0.13.ebuild
deleted file mode 100644
index 135c195e304e..000000000000
--- a/net-misc/tlsdate/tlsdate-0.0.13.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools eutils systemd vcs-snapshot user
-
-DESCRIPTION="Update local time over HTTPS"
-HOMEPAGE="https://github.com/ioerror/tlsdate"
-SRC_URI="https://github.com/ioerror/tlsdate/tarball/${P} -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ia64 m68k ~mips s390 sh sparc x86"
-IUSE="dbus +seccomp static-libs"
-
-DEPEND="dev-libs/openssl:0=
- dev-libs/libevent:=
- dbus? ( sys-apps/dbus )"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-tlsdated-service.patch
-)
-
-src_prepare() {
- # Use the system cert store rather than a custom one specific
- # to the tlsdate package. #534394
- sed -i \
- -e 's:/tlsdate/ca-roots/tlsdate-ca-roots.conf:/ssl/certs/ca-certificates.crt:' \
- Makefile.am || die
-
- default
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-silent-rules \
- $(use_enable dbus) \
- $(use_enable seccomp seccomp-filter) \
- --disable-hardened-checks \
- --without-polarssl \
- --with-unpriv-user=tlsdate \
- --with-unpriv-group=tlsdate
-}
-
-src_install() {
- default
-
- # Use the system cert store; see src_prepare. #446426 #534394
- rm "${ED}"/etc/tlsdate/ca-roots/tlsdate-ca-roots.conf || die
- rmdir "${ED}"/etc/tlsdate/ca-roots || die
-
- newinitd "${FILESDIR}"/tlsdated.rc tlsdated
- newconfd "${FILESDIR}"/tlsdated.confd tlsdated
- newinitd "${FILESDIR}"/tlsdate.rc tlsdate
- newconfd "${FILESDIR}"/tlsdate.confd tlsdate
-
- systemd_newunit "${S}"/systemd/tlsdated.service tlsdated.service
- systemd_newtmpfilesd "${FILESDIR}"/tlsdated.tmpfiles.conf tlsdated.conf
- insinto /etc/default
- newins "${FILESDIR}"/tlsdated.default tlsdated
-
- insinto /etc/dbus-1/system.d/
- doins dbus/org.torproject.tlsdate.conf
-
- use static-libs || \
- find "${ED}"/usr '(' -name '*.la' -o -name '*.a' ')' -delete
-}
-
-pkg_preinst() {
- enewgroup tlsdate 124
- enewuser tlsdate 124 -1 /dev/null tlsdate
-}