summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2020-11-27 19:13:30 +0100
committerSam James <sam@gentoo.org>2020-12-15 04:00:36 +0000
commit43f5f02c5f036d7a9d73f0a621d81b734e74913a (patch)
tree0c01416016e822d897f25ebe6399ad8a5f437f4b /net-misc/unison
parentapp-text/scdoc: cleanup old (diff)
downloadgentoo-43f5f02c5f036d7a9d73f0a621d81b734e74913a.tar.gz
gentoo-43f5f02c5f036d7a9d73f0a621d81b734e74913a.tar.bz2
gentoo-43f5f02c5f036d7a9d73f0a621d81b734e74913a.zip
net-misc/unison: bump to 2.51.3_p20201127
Closes: https://bugs.gentoo.org/758386 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/unison')
-rw-r--r--net-misc/unison/Manifest1
-rw-r--r--net-misc/unison/metadata.xml8
-rw-r--r--net-misc/unison/unison-2.51.3_p20201127.ebuild111
3 files changed, 119 insertions, 1 deletions
diff --git a/net-misc/unison/Manifest b/net-misc/unison/Manifest
index 3a032f493168..6621fe5cba89 100644
--- a/net-misc/unison/Manifest
+++ b/net-misc/unison/Manifest
@@ -2,3 +2,4 @@ DIST unison-2.48.15v4.tar.gz 1911781 BLAKE2B d3dabea1b8b0d2a8c64716144d33265ba90
DIST unison-2.48.4-manual.html 278110 BLAKE2B 8a85662399aff31a016964783b32c195cb32f5e6bab44c2f0f08740ab88393f4c73b98ecf58d6930bf103c1bec45720306343fa9fe39d3cdd73ffbbac2b9093c SHA512 b995712cda51d612bd81c89589d872099b3b9c90f7413268b24ab399a1eff7690200980514a834ee3d12bd3c89ef61bb8a29b3970c01433e0c4671d363a96b68
DIST unison-2.48.4-manual.pdf 516093 BLAKE2B 8e752a01b8c4335d6687b1f4f20ee09fda90b7521b7ed87af43273416fb3119682078d969772e8c3f7395ef499257dafd67c455a4646868008090ea15063869e SHA512 514da1eda0405416e53b1c8e027d39a803f9030824deccfaf5630aec21c52c6c9ea0d1006461faa8fb26738f4a33eecfe1ae24126fdb7a53ada6b90db270e6c9
DIST unison-2.51.3_p20201024.tar.gz 1371551 BLAKE2B 780cc176ed203345408551aaa11990e4da1ec0d4adfd928f3e8ff9c180f35fafb6ac097c00c95da8fe9178db122ea025e9f4336413f0694cea099ab80e2ae00e SHA512 87c7ce33621bc323607e901547da30b8fc0a842ba35128627f5d44fb4befd76ff94586ec1f8eb1f3359da756d09d8bf2481cf0d6eb2ea421113e0e4efdcbdf61
+DIST unison-2.51.3_p20201127.tar.gz 1374770 BLAKE2B 83c133f2cb99e10fac96efde333291a671edab5eb45dd6dcf56cb25845385425353a5f413ab752361124ec7bbac21daf3f813d5539b21229d943cf7f0bfae2fd SHA512 4b978a5e3df620317b7a9214054d64f319d09c5617b07ddf3cf76b18c6888841ce791f7b6a4ef70c64b146e3e4f25a5904584fb576703c2de4b17cfcffa8905a
diff --git a/net-misc/unison/metadata.xml b/net-misc/unison/metadata.xml
index 6f49eba8f496..5d879286e9ff 100644
--- a/net-misc/unison/metadata.xml
+++ b/net-misc/unison/metadata.xml
@@ -1,5 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">bcpierce00/unison</remote-id>
+ <bugs-to>https://github.com/bcpierce00/unison/issues</bugs-to>
+ <doc>https://github.com/bcpierce00/unison/wiki</doc>
+ <changelog>https://www.cis.upenn.edu/~bcpierce/unison/changes.html</changelog>
+ </upstream>
</pkgmetadata>
diff --git a/net-misc/unison/unison-2.51.3_p20201127.ebuild b/net-misc/unison/unison-2.51.3_p20201127.ebuild
new file mode 100644
index 000000000000..f1758eeb5557
--- /dev/null
+++ b/net-misc/unison/unison-2.51.3_p20201127.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg-utils
+
+MY_COMMIT="4713e608d2f9c998ba4412fee53b94dc9bef98b9"
+DESCRIPTION="Two-way cross-platform file synchronizer"
+HOMEPAGE="https://www.seas.upenn.edu/~bcpierce/unison/"
+SRC_URI="https://github.com/bcpierce00/unison/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="debug doc gtk +ocamlopt threads"
+RESTRICT="!ocamlopt? ( strip )" # https://bugs.gentoo.org/685776#c0
+
+# ocaml version so we are sure it has ocamlopt use flag
+BDEPEND="dev-lang/ocaml:=[ocamlopt?]
+ doc? ( app-text/dvipsk
+ app-text/ghostscript-gpl
+ dev-texlive/texlive-latex )"
+DEPEND="gtk? ( dev-ml/lablgtk:2= )"
+RDEPEND="gtk? ( dev-ml/lablgtk:2=
+ || ( net-misc/x11-ssh-askpass net-misc/ssh-askpass-fullscreen ) )
+ >=app-eselect/eselect-unison-0.4"
+
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+DOCS=( BUGS.txt CONTRIB INSTALL NEWS README ROADMAP.txt TODO.txt )
+
+src_prepare() {
+ # https://github.com/bcpierce00/unison/issues/416
+ sed -e "/ifdef\ HEVEA/,/endif/d" -i doc/Makefile || die
+ # https://github.com/bcpierce00/unison/pull/415
+ sed -e "/myName/d" -i doc/docs.ml || die
+ default
+}
+
+src_compile() {
+ local myconf="all"
+
+ if use threads; then
+ myconf="$myconf THREADS=true"
+ fi
+
+ if use debug; then
+ myconf="$myconf DEBUGGING=true"
+ fi
+
+ if use gtk; then
+ myconf="$myconf UISTYLE=gtk2"
+ else
+ myconf="$myconf UISTYLE=text"
+ fi
+
+ use ocamlopt || myconf="$myconf NATIVE=false"
+
+ # Discard cflags as it will try to pass them to ocamlc...
+ emake $myconf CFLAGS=""
+
+ if use doc; then
+ myconf="$myconf docs HEVEA=false"
+ emake $myconf CFLAGS=""
+ fi
+}
+
+src_test() {
+ emake test CFLAGS=""
+}
+
+src_install() {
+ # install manually, since it's just too much
+ # work to force the Makefile to do the right thing.
+ local binname
+ cd src || die
+ for binname in unison unison-fsmonitor; do
+ newbin ${binname} ${binname}-${SLOT}
+ done
+
+ if use gtk; then
+ newicon -s scalable ../icons/U.svg ${PN}-${SLOT}.svg
+ make_desktop_entry ${PN}-${SLOT} "${PN} (${SLOT})" "${PN}-${SLOT}"
+ fi
+
+ # Waiting for https://github.com/bcpierce00/unison/issues/411
+ if use doc; then
+ DOCS+=( ../doc/unison-manual.pdf )
+ # HTML_DOCS=( "${DISTDIR}/${P}-manual.html" )
+ fi
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "Unison now uses SLOTs, so you can specify servercmd=/usr/bin/unison-${SLOT}"
+ elog "in your profile files to access exactly this version over ssh."
+ elog "Or you can use 'eselect unison' to set the version."
+ eselect unison update || die
+
+ if use gtk; then
+ xdg_icon_cache_update
+ fi
+}
+
+pkg_postrm() {
+ if use gtk; then
+ xdg_icon_cache_update
+ fi
+}